In 2.79 I used to create several Render Layers in order to optimize rendering time. I sometimes use a sphere with an emission shader to simulate the sky. It doesn't require many samples to be rendered accurately. So having a sky rendered with a minimal number of samples and the rest with bigger samples numbers was quite efficient. And as compositing is powerful in blender; all was kind of easy.

In 2.80 I can group objects in collections make several "View Layers" and use "Holdout" to achieve the same thing for compositing. But I cannot find any individual View Layers setting for samples. I have one setting and it seems to be global.

In other words I'm looking for a "per View Layer Sample setting". What I would like to achieve is to render my "sky View Layer" at 8 samples (as an example) and the other View Layers at 640 samples.

I can't find anything on the matter to my despair.


The suggestion to use >Scene>ViewLayerXXX>Override>Sample doesn't seems to work. I tried different values than the global one (=23 samples) for each ViewLayer and it end up rendering with the global setting. Both on Linux and Windows10 version (x64 portable packages)

Rendering with the override setting

This may suggest that >Scene>Render>Sampling>Layer Samples=Use isn't related to ViewLayer, though it could be appropriate considering the 2.79 -> 2.80 context.

  • $\begingroup$ The render settings are shared for view layers in a scene. You can create another scene with different settings though. Not sure if that's helpful for what you had in mind. $\endgroup$ Commented Aug 2, 2019 at 16:20
  • $\begingroup$ Well... If i have to create several scenes to get it working like i want; it's kind of defeating the purpose of collections and ViewLayers in my opinion. I'll try that to see if it creates a mess or not. $\endgroup$
    – 4E71-NOP
    Commented Aug 2, 2019 at 21:23
  • $\begingroup$ I just spotted the edit saying that this didn't work in 2.80 and have re-tested with my current Blender version (2.91.2) and this seems to be working as described - ie, I created two View Layers - one with Override Samples set to 5 and the other set to 5000. This seems to have correctly used the overridden number of samples for each layer. If you're still having problems at the most recent Blender version then it would be worth raising as a bug if you can't explain it any other way. $\endgroup$ Commented Mar 4, 2021 at 11:41

1 Answer 1


The setting is still there - but it is in a different location. You now need to look to the Override panel where you'll find the Material override as well as the Samples override.

override panel


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .