0
$\begingroup$

I downloaded fresh Blender 2.80 for Linux64, but it is crashing on my Debian Linux (with Nvidia card), see below. Any help, please ?


[email protected]:~/Work/software/blender/../blender 
Color management: using fallback mode for management
Color management: Error could not find role data role.
BLT_lang_init: 'locale' data path for translations not found, continuing
Color management: scene view "Filmic" not found, setting default "Standard".
Received X11 Error:
        error code:   8
        request code: 155
        minor code:   34
        error text:   BadMatch (invalid parameter attributes)
Received X11 Error:
        error code:   8
        request code: 155
        minor code:   34
        error text:   BadMatch (invalid parameter attributes)
Fatal Python error: initfsencoding: unable to load the file system codec
ModuleNotFoundError: No module named 'encodings'

Current thread 0x00007f0859b59fc0 (most recent call first):
Aborted
[email protected]:~/Work/software/blender/.uname -a
Linux lxg1213 3.16.0-9-amd64 #1 SMP Debian 3.16.68-2 (2019-06-17) x86_64 GNU/Linux
$\endgroup$
1

1 Answer 1

0
$\begingroup$

SOLVED.

One has to launch blender from within the downloaded package - then it takes in all libraries etc.

Although it claims X11 error, the blender shows up.


[email protected]:~/Work/software/blender/blender-2.80-linux-glibc217-x86_64/../blender
Received X11 Error:
        error code:   8
        request code: 155
        minor code:   34
        error text:   BadMatch (invalid parameter attributes)
Received X11 Error:
        error code:   8
        request code: 155
        minor code:   34
        error text:   BadMatch (invalid parameter attributes)
found bundled python: /u/milias/Work/software/blender/blender-2.80-linux-glibc217-x86_64/2.80/python
Writing userprefs: '/u/milias/.config/blender/2.80/config/userpref.blend' ok
$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .