0
$\begingroup$

As the titles says I'm having issues creating a portal that has another world in it. I tried the following guide to the letter: Creating the Minecraft End Portal in Blender but it isn't working. I was hoping someone could take a look at my file and tell me where I am messing up and what I am missing. Preferably with images because I'm still new-ish to blender and don't know all the names or locations of every function but any help is completely and utter welcome! I am destroying my brain over this! LOL!

My goal is to have the crystals be only seen inside the portal/gold object in the sense. Thank you so much in advanced!

Here is the file: https://mega.nz/#!T2xhwKrQ!ZHjC0fWvLK3gdJn3WQ8kWJquqJFmNGVTepUfXwxK6eI

$\endgroup$
  • 1
    $\begingroup$ The correct way to achieve this is through render layers and compositing. $\endgroup$ – Yvain Aug 1 '19 at 22:01
  • $\begingroup$ Thank you so much for replying back! But may I ask for a little more detail? Sorry, as I said I'm a bit new-ish to blender and have only once, and with very mixed results, used render layers! Lol! How would you go about achieving this? $\endgroup$ – MrAlenko Aug 3 '19 at 2:26
2
$\begingroup$

Ok this is a tutorial on how to create a portal using scenes, render layers, object id and compositing. Please try to achieve it while reading the tutorial.

First you want to have the first world and the portal.

enter image description here

Note that i set the plane pass index to 1, this is crucial.

Then you need the second world, I did a terrain with a sunlamp. Create them in the second scene and link your camera here afterward (ctrl+L->link to scene).

enter image description here

After this you need to set up the render layers, for use with compositing. Go to render layer panel, unfold the pass menu and select object index

enter image description here

For the scene 2, you don't need to set the object index because the plane you will be using for splicing the two world is only present in the first scene.

Everything is setup, open the node editor and select the compositing nodes.

Here you start with a render layer that is set on render layer one, scene one (we are just using one scene in our case) and a composite output.

Just add another render layer, set in on scene 2, add an alpha over node and connect your two layers color output on that node, the factor is the plane, so connect the indexOB that we activated earlier for the first layer to an IDMask node then to the factor of the alpha over. Easier to just look at the picture here:

enter image description here

Now you can just render.

enter image description here

Being an after effect, there is no such thing as compatibility issues regarding wether you are using cycles, eevie, or blender internal.

$\endgroup$
  • $\begingroup$ You, my friend, are a GOD! Thank you so much! This did the trick! I really appreciate you taking the time out of your day to help me! $\endgroup$ – MrAlenko Aug 3 '19 at 18:22
  • $\begingroup$ You'r welcome. Fact is I had tried this a long time ago without succes but this time it worked. So thank you for asking and having been patien $\endgroup$ – Yvain Aug 3 '19 at 20:44
  • $\begingroup$ Hi @Yvain thanks for this solution, its great. I have one question - you mention that since it is an after effect it doesn't matter whether you are using cycles, eevee etc. However, I am using 2.8 and it is not possible to do this step "After this you need to set up the render layers, for use with compositing. Go to render layer panel, unfold the pass menu and select object index" when in eevee - as object index does not exist as a check in the layer panel. Is there an alternative way? I would love to be able t do this in eevee. Thanks. $\endgroup$ – Nick Sep 18 '19 at 14:21
  • $\begingroup$ Yes you are right, I was working in 2.7 and did not notice that eevee has no support for render layers. I don't know how you could do this, this might be impossible, you might find a way... but I would advise that you use cycles and stick to this. There are many way to optimize your render so that it's not too long, especially look upon the filter glossy setting and don't use an unnecessary high amount of light bounces. Your render will just be great and more realistic that with eevee. $\endgroup$ – Yvain Sep 18 '19 at 15:07
  • $\begingroup$ Hi, thanks for getting back. I don't mind doing it in cycles, its just, as you mention, it takes a lot longer. I just looked at the filter glossy setting which is currently at 1 - should it go up or down to speed it up? Also light bounces are set by default at 12 - what would be a reasonable setting? Your advice is much appreciated. $\endgroup$ – Nick Sep 18 '19 at 16:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.