8
$\begingroup$

When I try to import my obj file in Unreal I keep getting this error.

"No smoothing group information was found in this FBX scene. Please make sure to enable the 'Export Smoothing Groups' option in the FBX Exporter plug-in before exporting the file. Even for tools that don't support smoothing groups, the FBX Exporter will generate appropriate smoothing data at export-time so that correct vertex normals can be inferred while importing."

I never got this error when I used Blender 2.78b, so I make models in 2.8 and after that I import obj file to 2.78b and export as obj again with same settings with this Unreal doesnt show any error messages.

But I dont want to go 2.8 then 2.78b then Unreal.

Right now when I export a obj file I chose this boxes.

Selection Only : Depends

Animation : No

Apply Modifiers : Yes

Include Edges : Yes

Smooth Groups : Yes

Bitflag Smooth Groups : Yes

Write Normals : Yes

Include UVs: Yes

Write Materials : No

Triangulate Faces : No

Write Nurbs : No

Polygroups : No

Objects as OBJ objects : Yes

Objects as OBJ Groups : Depeds

Material Groups : No

Keep Vertec Order : No

$\endgroup$
2
  • $\begingroup$ You're mixing two things here .obj and .fbx files. Seems like Unreal doesn't like .obj files and wants .fbx instead? So I assume using .fbx as export format is what you need to do. $\endgroup$ Commented Aug 1, 2019 at 17:06
  • $\begingroup$ Unreal have no problem with .obj files when I export them with blender 2.78b but you right. I dont want to export .fbx files because they are almost x9 times bigger then .obj files. Maybe its time to switch to .fbx ,thanks. $\endgroup$
    – Enes Ozgun
    Commented Aug 1, 2019 at 18:42

1 Answer 1

14
$\begingroup$

Set Smoothing under the Geometry tab to Face in the FBX export settings when exporting.

enter image description here

$\endgroup$
2
  • $\begingroup$ I am trying to export them as .obj file because .fbx files generally bigger but if I will decide to switch .fbx I will definitely use this thanks. $\endgroup$
    – Enes Ozgun
    Commented Aug 1, 2019 at 18:42
  • $\begingroup$ confirming this resolved the error with Blender 2.82 and Unreal Engine / Unreal Editor 4.25 . Thank you! $\endgroup$
    – HongPong
    Commented May 17, 2020 at 2:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .