6
$\begingroup$

I'm trying to get clean, one pixel wide lines on my renders like the pic below, but nothing I try seems to work.

The lines I'm trying to get

I've tried freestyle with one sample, but I get extra pixels at some parts of the strokes and the low sampling makes the rest of the render look really bad.

Freestyle Lines

I also tried this compositor nodegroup and this script, but I can't make the nodegroup's lines thin enough and the script just doesn't work at all.

These were the thinnest lines I could get with the nodegroup.

Nodegroup lines

So is there any way to render lines like the first pic, or am I out of luck?

I'm fine with using either engine.

$\endgroup$
4
  • 1
    $\begingroup$ Have you set the pixel filter to box (Render Tab > Film) when you're using Cycles? $\endgroup$ – Robert Gützkow Aug 1 '19 at 16:22
  • $\begingroup$ Just tried it, this is what I got $\endgroup$ – Plecofish97 Aug 1 '19 at 16:33
  • $\begingroup$ Was just an idea, because that disable anti-aliasing. $\endgroup$ – Robert Gützkow Aug 1 '19 at 16:35
  • 1
    $\begingroup$ I can get similar results to my second pic by using the other two filter types on the smallest width, but they still aren't as clean as I'd like. $\endgroup$ – Plecofish97 Aug 1 '19 at 16:40
2
$\begingroup$

If you're ok with using the Workbench engine, you can simply go to User PreferencesViewportSmooth Wires and disable Overlay.
enter image description here

You can choose the Workbench engine just like Cycles or Eevee in the Render Properties tab, and since frames can still be rendered with transparency you could easily composite them into frames rendered with any other engine.
enter image description here

Result

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.