0
$\begingroup$

In my file I have a rigged character and a couple of different animations, i.e. actions. In the dope sheet/action editor I can select between these, and the yellow/white dots (I mean the dots that display where in the timeline a keyframe is for the given bone) get updated accordingly, so I'm sure the previous animation was saved with the .blend file.

However, when I scrub through the timeline, the character always performs the same, most recent action. So say the dope sheet is displaying the keyframes from a crouch animation, but when I move the cursor in the timeline to a specific point, the character in the 3D view will still perform the running animation!?

How can I go back to view and edit the actions I made before?

$\endgroup$
  • $\begingroup$ Actually I need to correct myself: The keyframes are displayed inside the action editor. When I change the mode to the actual dope sheet, it's always empty. Even though when scrubbing through the timeline, or pressing shift+space, the animation will play. $\endgroup$ – hifumi Aug 1 at 15:54
  • $\begingroup$ something must be playing in the NLA editor because you must have pushed down one of the action, so go in the NLA and deactivate the track? $\endgroup$ – moonboots Aug 1 at 15:58
  • $\begingroup$ I don't think that's it. I disabled everything from the NLA editor, made it completely empty. I managed to switch between the actions sometimes, but I can't figure out how to make it work reliably. I think it has something to do with having all the bones selected as well, as that sometimes seemed to make it work. Just one more of those confusing things about blender $\endgroup$ – hifumi Aug 1 at 17:44
  • $\begingroup$ maybe share your file (at least the animated armature): blend-exchange.giantcowfilms.com $\endgroup$ – moonboots Aug 1 at 20:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.