2
$\begingroup$

Hi so I'm completely lost on why this is happening in my viewport render in cycles but the image comes out completely grey. I've tried about every setting I can find and through these posts Render result is completely blank?, Why does my object not show up? but nothing seems to fix it. The weird thing is that this only happens in the rendered viewport shading. Not in look dev or solid in cycles, nor in EEVEE. enter image description here Any help would be appreciated.

$\endgroup$
2

2 Answers 2

1
$\begingroup$

I had the same problem and here is what I discovered: Under 'Properties > Output properties > Dimensions' I accidentally had the option 'Render region' checked. Once I unchecked this option, Cycles was back in bussiness. A simple solution but it can be very confusing if you don't know what's going on, since Eevee would render with this option checked. Hope some day this helps someone out there.

$\endgroup$
1
  • $\begingroup$ The Viewport Render Image rendering doesn't use Cycles. $\endgroup$ Feb 18 at 6:59
-1
$\begingroup$

If it's not the Render Region like Mark suggested, maybe your 3D Viewport is in Rendered preview mode? Viewport Render Image only renders the viewport as you see it when it's in Wireframe, Solid or Material Preview mode (when using the Cycles render engine).

//EDIT: Oh, you wrote it in the question you're in Rendered preview... yes, it is not supposed to render "real" renders, because it is supposed to do quick preview renders. From the manual: "Solid mode uses the render settings of Workbench; Material Preview mode uses the render settings of Eevee."

So, if you are using the Eevee render engine, it works in Rendered view, and if you are using the Cycles engine, it would be no quick preview anymore presumably.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.