0
$\begingroup$

I downloaded Animations from mixamo to import into my scene. In the mixamo webapp the animation plays back at 100fps. In Blender 2.8, its 7fps.

Solid mode, no modifiers, no materials. No other objects in the scene but a plane. Purely the imported FBX from mixamo.

What could be causing the framerate issues? Is there a way to remedy it so that the animation playsback at 24+ fps?


Currently running a Dell Insperon g5 with a gtx1060m and an Intel i5-7300hq 2.5ghz and 8gb of ram

$\endgroup$
  • $\begingroup$ IIRC (haven't done much mocap in 2.8 TBH) try one of the importer options to scale FPS such that the bvh action has one keyframe per frame, without a lot of inter frame keyframes. eg if bvh is 100fps and blender is 25fps you get 4 keyframes per frame, where 1 will do the trick. Also don't have dope sheet open when playing. $\endgroup$ – batFINGER Aug 1 at 9:22
  • $\begingroup$ I have been able to work-around the issue by reducing the graphical fidelity. $\endgroup$ – Adam Velazquez Aug 3 at 0:48
  • $\begingroup$ Recommend add more info to question. Some screenshots and optionally the blendfile, the bvh. What is the playback for just an armature in object or pose mode in 3d view (not in render mode), with no other editors open?.... lol started this comment an hour ago, didn't get around to posting. imagine having a VSE preview of the current scene open may slow it down somewhat. $\endgroup$ – batFINGER Aug 4 at 6:31
0
$\begingroup$

I found I could work around my issue by optimizing a few things. I want to stress that these are all to lighten the load of the CPU during playback and I have not found any way to make Blender's playback as reliably smooth as Mixamo's web player or Maya. I suspect this issue stems from how Blender's code handles hardware acceleration during playback. Something that would be far outside of my realm of expertise.

OPTIMIZING:

Models --

  1. Merged Unconnected overlapping Faces(Merge by distance)

  2. Remove Doubles

  3. Tris to Quads

  4. Apply Decimate modifier for a low res proxy model.

  5. Erase nonessential faces from low poly proxy model

Viewport:

  1. Use WorkBench

  2. Shade Single if possible

Ui:

  1. Remove as many panels as possible, this includes N and T menus.

  2. Ctrl+alt+space to fullscreen for smoothest playback

Misc:

  1. remove any VSE Preview panels

    1a. If you need a vse preview panel, set it to the lowest resolution proxy settings

In Solid mode, with these changes I was able to go from 7 fps to 45 fps with my single character In Eevee the difference was from 2fps to 14fps for the same scene.

Not a perfect solution but certainly a significant performance improvement, especially in solid mode.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.