0
$\begingroup$

So I'm trying to render the Spring demo but everytime I render it using GPU it crashes but if I render it on my CPU it doesn't crash. Does anyone having similar issues? My computer spec are 32gbs of ram, ryzen 2600x and gtx 1060. I'm thinking blender still has some stable issues still.

$\endgroup$
20
  • $\begingroup$ You could try to update your graphics driver nvidia.com/Download/index.aspx $\endgroup$
    – Robert Gützkow
    Aug 1, 2019 at 9:23
  • $\begingroup$ I rolled back my driver and it stills crashes and then I update my driver and it stills crashes $\endgroup$
    – J.Jesse
    Aug 1, 2019 at 20:13
  • $\begingroup$ What exactly means crashing in this context, is there any error message? Can you go to the install directory and start Blender with blender_debug_log.cmd and provoke the crash by using GPU (or on Linux with from terminal with the --debug flag). $\endgroup$
    – Robert Gützkow
    Aug 1, 2019 at 20:16
  • $\begingroup$ what I meant by crashing is that blender closes while rendering. I did get a crash report but I don't have a way to upload it. $\endgroup$
    – J.Jesse
    Aug 1, 2019 at 20:58
  • $\begingroup$ If it's short you could edit your question and put and a ` in front and after for proper formatting. If it's longer you could put the log file on Google Drive or something like this and post the link. $\endgroup$
    – Robert Gützkow
    Aug 1, 2019 at 21:05

5 Answers 5

3
$\begingroup$

While I can't pin-point the source of the issue, it seems to be caused by a problematic interaction of modal operators by some add-on or script and the auto-save feature which causes the TDR-Delay (Timeout Detection Recovery) to be exceeded.

The current workaround is to restore the factory settings. This can be done in Edit > Preferences. First load the factory settings by clicking on the button in the bottom right corner. Then save the preferences to make these changes permanent.

enter image description here

$\endgroup$
5
  • $\begingroup$ Thank you for the help $\endgroup$
    – J.Jesse
    Aug 2, 2019 at 17:01
  • $\begingroup$ @J.Jesse You're very welcome. $\endgroup$
    – Robert Gützkow
    Aug 2, 2019 at 17:03
  • $\begingroup$ I have this problem for a long time already and from time to time it causes me to lose significant amount of work. What it does, besides crashing PC with BSOD, is it corrupts the autosave file, and these don't come with .blend1 backups. :/ I can't find a single thread about it but this one on google, so I guess it's not a common issue. Were you able to pinpoint the issue by any chance? I don't really use unnecessary addons... $\endgroup$
    – Shaggy
    Sep 21, 2021 at 11:09
  • $\begingroup$ @Shaggy If you are getting a BSOD this is an issue outside of Blender. Most likely this would be an issue with your graphics driver, OS or a hardware problem. $\endgroup$
    – Robert Gützkow
    Sep 21, 2021 at 11:12
  • $\begingroup$ It seems like setting TDR delay times to ridiculous values much higher than the ones presented in online instructions fixed the issue. $\endgroup$
    – Shaggy
    Mar 3, 2022 at 11:26
2
$\begingroup$

I just started using a Dell G7 with Nvidia graphics, and I immediately started having the dreaded "Your computer had a problem ... we'll restart it for you ..." with a VIDEO TDR FAILURE error message. My complete setup is as follows:

System: OS Name Microsoft Windows 10 Home Version 10.0.17763 Build 17763 System Manufacturer Dell Inc. System Model G7 7790 System Type x64-based PC Processor Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz, 2592 Mhz, 6 Core(s), 12 Logical Processor(s) BIOS Version/Date Dell Inc. 1.6.0, 6/1/2019

Video: Adapter Description NVIDIA GeForce GTX 1660 Ti Adapter RAM (1,048,576) bytes Driver Version 26.21.14.3153

Blender: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47 Rendering with Cycles or Eevee. Graphics interface: CUDA (unable to find version)

So, being a software veteran of many, many years, I'm tolerant and inquisitive. I found some reference (and subsequently lost it) to a Registry setting for TDR Timeout. It seems that the graphics system interface keeps tabs on whether the graphics driver is hung or not, and if the interface hangs for more than a certain time, it throws a fit and dumps some data somewhere. It then proceeds to restart the computer.

I looked around in the registry and found the following:

Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\TdrWatch

The initial or default setting on my system (as described above) was "Value not set". Well, that strikes me as terribly uninformative, so I had read somewhere that the default was meant to be two seconds. I upped it to first 5 and then 10 seconds, restarted the computer and Blender, and proceeded to try to make Blender and the video fail.

Interesting observation: when it seemed that Blender was totally unresponsive, I started counting seconds until the crash. When I had the timeout set to 5 seconds, the crash came 5 seconds after I noticed the Blender stasis. When I moved the timeout to 10 seconds, I could count 10 seconds before the apocalypse. I also noted that several times when Blender became unresponsive, it might recover and become responsive again as long as the delay was less than the 10 seconds I had set.

What this says to me is that the Nvidia driver coupled with Blender 2.8 somehow generates an occasional spate of "hung". The pair will sometimes recover, and all is fine. These hang times varied from less than a second to several, but fewer and fewer times did the hang exceed 10 seconds.

DISCLAIMER: I messed with my Registry on my own computer. Do not do this unless you are a trained Windows technician; you could damage or destroy your operating system or hardware. Don't say I didn't warn you!

Update 9/19/19: Nvidia came out with a "studio" driver update just last week. The studio version is meant for "production users" as opposed to gamers, so I downloaded and installed. It's been a week now with no die-and-reboot. Things are looking up. I've been switching from Blender to a browser (Firefox) to GIMP to Camtasia with no problem. It's only been a week, but I used to get these every day before. Maybe the Nvidia driver was it. I'll wait a week and then reset my TDRWATCH timeout to default and see what happens. One thing I did notice is that a really heavy graphics use will sometimes "pause" for one to 5 seconds and then resume. Here's hoping.

$\endgroup$
3
  • $\begingroup$ Can you send me the link to the studio drivers $\endgroup$
    – J.Jesse
    Nov 25, 2019 at 21:41
  • $\begingroup$ Here's the page I got it from. Note that I had to specifically choose the Studio Driver. You should of course use your computer's info. nvidia.com/Download/index.aspx?lang=en-us I followed this link just now, and I got a driver dated 2019.11.18 - later yet, so I guess they're still changing things. Mine is from 2019.8.7. For the record, I haven't had one single crash since, and I've stressed it with big cycles renders in Blender. Of course, Windows 10 has done several updates in the meantime, and Dell did an update, but I think that was for other stuff. Good luck. $\endgroup$ Nov 27, 2019 at 4:22
  • $\begingroup$ Thank you for the link. $\endgroup$
    – J.Jesse
    Nov 27, 2019 at 4:27
1
$\begingroup$

Lumiere-V0.3-for-2.8-master.zip free addon corrupts render animation and pyton scripting and many other functions of blender

I removed the free addon and reinstall blender 2.9 /2.8 Blender is in excellent condition

$\endgroup$
0
$\begingroup$

I had the same and it ended when I disabled D-NOISE addon (from NVidia). Still testing though.

$\endgroup$
0
$\begingroup$

Disable Render > Performance > Final Render > Persistent Images.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .