1
$\begingroup$

In Blender 2.71, I am trying to use the Blur compositing node to make some blue emitting lines have a glow around them.

Here is the render without the blur: this is to be blurred

This is what I am getting: fail blur attempt

This is what I want (blur done in GIMP): desired result

So what is going on? It honestly looks like the Blur isn't sampling every pixel of the rendered image and is skipping large chunks. Is there any way to fix this?

Oddly, the cycles autorendered image does it correctly. Just not when I click the Render or Animate buttons.

Edit: Here is the Blur Node I am using: Blur Node

I'm actually using 3 of them, combining them with Add nodes. The three nodes have, for their X and Y, 10, 15, and 20.

I've tried all the other types of blurs beside Gaussian that are available in the drop-down. I've tried clicking all the check-boxes in the node. I've tried reducing the Image Size. Every attempt has had some form of patchy blur.

I did discover that if I increase the image resolution to 4 times that of normal HDV resolution, I can almost make the patchiness go away, at the expense of taking a very long time to render.

$\endgroup$
  • $\begingroup$ Which blur method are you using? $\endgroup$ – gandalf3 Aug 4 '14 at 6:47
  • $\begingroup$ Gaussian, but I've tried all the others too. $\endgroup$ – Outrider Aug 4 '14 at 8:20
  • $\begingroup$ And the blur size? $\endgroup$ – Greg Zaal Aug 4 '14 at 12:06
  • $\begingroup$ I think the problem is frame size your're using. HDV uses non-square pixels (1440x1080 4X3 aspect ratio). Try full HD (1080x1920)with square pixels $\endgroup$ – user1853 Aug 4 '14 at 19:43
  • $\begingroup$ Changing the resolution from HDV (1440x1080 4x3) to HDTV (1920x1080 1x1 aspect ratio) only succeeded in moving the patchiness around, not eliminating it. $\endgroup$ – Outrider Aug 4 '14 at 23:31
2
$\begingroup$

I found the solution! It was the Anti-Alias setting on the ID-Mask node that was causing the problem. Apparently it was causing the render of those thin lines to be patchy, resulting in a patchy blur. Once I turned off the Anti-Alias, everything was fine!

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.