1
$\begingroup$

Up until 2.8, I was able to disable mipmapping in the preferences (which for some reason, disabled texture filtering), however this option is now unfortunately missing. I understand I can use nodes to create unfiltered renders but I need this for pixel-perfect editing as the models will be exported.

Another issue I have it that textures now longer show up in 'look dev' mode without a material. (previously alt-z).

Until I can fix these, I have to revert to 2.79a. Any help would be very much appreciated.

Thank you

$\endgroup$
  • $\begingroup$ You can set the texture interpolation on the image node to closest and to disable antialiasing set the pixel filter to box (Render tab > Film). I'm not quite sure what your issue with textures in look dev mode is, if you connect a texture node with your material it will be displayed. $\endgroup$ – Robert Gützkow Jul 31 at 12:52
  • $\begingroup$ Hello. Thank you for your comment, however; please read my post carefully. I know how to use nodes and how to disable texture filtering for renders. I am speaking about unfiltered textures in regular edit mode. $\endgroup$ – Bevan Aug 2 at 12:53
  • $\begingroup$ I was looking the same thing but I found this link: blenderartists.org/t/… I hope this helps $\endgroup$ – Gerardo Gonzalez Cruz Oct 13 at 19:24
0
$\begingroup$

Under the shading tab, add an environment texture and set it to closest and connect the node up.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.