0
$\begingroup$

Before the issue:

For the past few weeks I've been doing a few animations on a Character with an Armature, with a pretty good certainty that I had the scale at 1.

Turns out, somehow in the middle of the process, (despite not being changed in size / scale since its creation) the Armature ended up with a similar scale to the character - which was set to about 0.10.

Probably happened automatically during the parenting and I didn't notice it?

I've been trying to come up with solutions to change their scales back to 1 without affecting the animations and I recently found out that

  • using ALT + S does exactly just that.

Current issue:

However...

I now have the issue of having - although properly scaled meshes and armature - really huge dimensions on both.

If I would export this into UE4 it would be ridiculously large.

On the same note, although having the same size and (now) scale, my Armature has nearly 13m in height while my mesh has only near 3?

Question 1: Does this difference in dimensions affect anything during the export? Question 2: How can I change these dimensions without affecting the animations in any way?

Would really appreciate the help!

TL;DR: I've tried Applying Scale. Scale and Rotation too.

But I only found ALT + S to help with the Scale without affecting my animations and now I have huge dimensions on my mesh and my armature.

How do I change these without ruining the animations?

$\endgroup$
0
$\begingroup$

apply scale and rotation

  • CTRL + A

las dimensiones no se cambian, solo puede cambiar la escala

CTRL + A

$\endgroup$
  • $\begingroup$ Unfortunately using this method changes my poses and therefore my animations :( That's why I'm asking for help here haha $\endgroup$ – SDpt Aug 1 at 12:05
  • $\begingroup$ in your question you never mention this, so you are answered according to what your question says, and your question is not understood, besides you are asking a lot of questions when you only have to ask individual questions $\endgroup$ – user58715 Aug 1 at 12:12
  • $\begingroup$ Ask your question to understand what you are looking for $\endgroup$ – user58715 Aug 1 at 12:12
  • $\begingroup$ I did say I spent hours on this and that the only way I found to change the scale without affecting the animations was by using Alt+S, though. I just assumed that was clear enough to say that I've tried everything related to the scale ^^" If that wasn't clear, I apologize. My problem is the dimensions of the object and the armature. $\endgroup$ – SDpt Aug 1 at 12:55
  • $\begingroup$ no problem I also had it but it was not difficult to solve it and just use what I show I did not have animations even though it was easy for me to unclog the armor and apply scales and re-match the armor, that gave me a clean solution that would be the most recommended $\endgroup$ – user58715 Aug 4 at 17:52
0
$\begingroup$

I actually just found this thread on a subreddit: https://www.reddit.com/r/blenderhelp/comments/8eqx0g/armature_apply_scale_without_destroy_the/

--

Doesn't the scale of the armature need to be 1,1,1 for it to be exported correctly onto an engine?

$\endgroup$
  • $\begingroup$ I had tried this, but I was assuming the scale of the armature should be 1 as well, so I dismissed it. Was I wrong? $\endgroup$ – SDpt Aug 1 at 13:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.