4
$\begingroup$

I'm trying to create a black hair material with random streaks of gray. I came up with the following setup:

Attempt at a streaked hair shader

At first, this appeared to work well. I was using a basic MakeHuman model, separated a skull cap and another part of the head mesh for facial hair. The first test renders looked like I wanted them: most of the hair was using the black shader with a bit of the gray shader thrown in. This seemed to work the same for both the scalp hair and the facial hair (see left image below - it's kind of hard to tell with the close-cropped beard but you can definitely see the streaks by looking at at the hairline - especially in comparison to the later render on the right).

As far as I can tell the problems started when I duplicated (Shift-D) the model to create a second character with slightly different characteristics. I did make sure to create new Particle Systems and Settings for the duplicated character and gave unique names to each. However, all of a sudden, when I rendered the original model all the scalp hair uses only the black shader while all of the facial hair uses only the gray shader (see right image below). It seems the random node is no longer evaluated per particle but only per object...

Before and after the problem

If I change the position of the slider on the top color ramp (the "selector" if you will) to something like 0.1 or 0.9 then Blender will render all hair with either one or the other shader.

Any idea what might have caused this or more importantly, how I can reverse the effect? Is there maybe a better approach for the "streaks"-effect I'm looking for?

Using Blender 2.71. The model was exported from MakeHuman Alpha 7. The scalp hair object uses only one particle system while the facial hair object has three (moustache, cheeks and soul patch).

$\endgroup$
2
$\begingroup$

Try using a noise texture and plug it in the factor of your mix shader. Play with the settings of the noise texture and maybe add a color ramp in between for even more control!

$\endgroup$
  • $\begingroup$ Thanks, that works great indeed! Still would have been interesting to know why my previous shader stoped working when I duplicated the model... $\endgroup$ – Oliver Giesen Aug 4 '14 at 20:00
  • $\begingroup$ Yeah that weird indeed! $\endgroup$ – Bert VdB Aug 4 '14 at 20:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.