1
$\begingroup$

So since months I am experiencing that cycles is getting slower and slower for me in Blender 2.8 and I thought with the release coming it might become better.

However when I have a very simple scene and use cycles to have preview it takes several seconds just to update small position adjustments i make to a sun lamp for example.

I do not know if I am having a setting wrong so it would be really nice if someone could help me.

I use a GTX 1070 as GPU and have enabled it. Tile size is 240x256 (autotile) viewport tile: I tried 64, 128, 256, 512. CPU is i7 6700K and 16GB DDR4 2800Mhz.

$\endgroup$
7
  • 1
    $\begingroup$ I'm not sure how simple your simple scene is. Cycles isn't really meant for real-time rendering/preview, that's what Eevee is for. Although Cycles needs time to render the samples in preview I haven't experiences it becoming slower over the course of the development. It does become slower with growing scene complexity. $\endgroup$ Commented Jul 24, 2019 at 9:09
  • $\begingroup$ Well, yes you are right that it is not meant for a real time rendering / preview, however it was always able to show me complex scenes in 2.79 and i could adjust lights etc. As for the scene, My profile picture is the scene ^^, really just 3 lowpoly buildings and really no difficult materials. $\endgroup$
    – Sasha
    Commented Jul 24, 2019 at 10:02
  • $\begingroup$ That should work fine. Can't give you a definitive answer, but I can suggest the following: The first thing I would check is that your GPU is selected as CUDA device in Preferences > System > Cycles Render Devices > CUDA to rule out that it uses integrated graphics. Then I'd update the graphics driver: nvidia.de/Download/index.aspx?lang=en $\endgroup$ Commented Jul 24, 2019 at 10:26
  • $\begingroup$ "takes several seconds just to update small position adjustments" Small or big, adjustments require recalculating and re-uploading the scene, there are no optimizations here as far as I know, so regardless of how small the change is it will re-render everything $\endgroup$ Commented Jul 24, 2019 at 11:57
  • $\begingroup$ Hi, thanks for the replys guys! Yes the GPU is set as cuda and it is using the 1070. Sorry i dont know how to quote, Before it was not like that. I could handle heavy glass shaders, the engine started of course to render unless i moved something so it had to start again but now it takes several seconds maybe up to 25 seconds till it even starts doing that. Before it was immediate. I think I should capture what I mean and upload it right? Maybe it would be easier to understand what I mean. $\endgroup$
    – Sasha
    Commented Jul 24, 2019 at 13:51

1 Answer 1

0
$\begingroup$

Try to use combined GPU AND CPU for rendering. Using square tiles will increase render speed (any square numbers "X²" for better performance). You can find some sites to help you minimizing the render time.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .