0
$\begingroup$

I've looked over the net and found nothing about this, so it may be some setting I have wrong. I'm using the newest version of 2.8 and it may have some option settings that were carried over from a previous 2.8 version.

I have a hard time aiming the cursor at bones to select them. I can aim directly at a bone and click it, but nothing happens. I usually have to aim at the edges of them to get a confirmed click, but even that doesn't always work.

Sometimes it seems like I have to aim at the very top or bottom of a bone's center area to get it to react. But these are just crazy theories. Obviously something is wrong. I haven't worked with bones in Blender before this version, so I have no idea if it is something that changed.

It only seems to happen with the octahedral shape. I can select other shapes fine, but I prefer to see the angles of bones more clearly, which only seems to be possible with that shape type (apart from making angles visible).

Is this something everyone deals with? Is there any way to make it better?

Thanks for any help!

EDIT: It is almost as if there is a clickable screen-space border surrounding the bones. If I click in their center, nothing happens. But if I then zoom the view out and click the exact same area, it works.

EDIT2: Apparently it doesn't seem to happen on my laptop, so it must be a specific situation with hardware or settings. Will add another edit if it starts happening on this computer.

EDIT3: Okay, not specific to any computer. It only happens when X-Ray is enabled. Which I usually always have it enabled so I can see the bones inside the skinmesh. Any ideas why this happens or how to improve it?

$\endgroup$
  • $\begingroup$ is your gizmo displayed? maybe it's because of it, I've also noticed that it prevents to easily select the bone, because Blender thinks you try to select the gizmo instead. Maybe it will be fixed... $\endgroup$ – moonboots Jul 24 '19 at 8:47
  • $\begingroup$ No, I think I may have disabled gizmos early on. I only see a transform gizmo when I select a specific tool such as translate or rotate. Typically I just press G or R instead, so don't see the gizmos. My guess is that Blender is accidentally or intentionally converting bones into some type of edge-only mode during X-Ray mode, where only the outline shapes of bones are interactive for the mouse. $\endgroup$ – Robert Aug 5 '19 at 17:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.