0
$\begingroup$

Every time I try to move my foot bone it just moves totally out of place. I don't get it. It seems like everything is done right.

Bones:

Thigh Leg : Child of Body/Head Bone.

Low Leg : Child of Thigh Bone.

Foot : Child of Nothing.

Toes : Child of Foot.

Low Leg IK Constraint : Target = Foot. Pole Target = Knee IK Pole Angle = -90 & Chain Length = 2. Everything else default.

Low Leg IK: X = Unlocked / Limited / 0 - 180 Y = Locked Z = Locked

My foot mesh is parented to my foot bone as Bone and not Automatic weights.

I just don't understand what the heck is happening?

feels like everything is done precisely.

Help would be much appreciated.

Before

enter image description here

After

enter image description here

$\endgroup$
  • 1
    $\begingroup$ Try aplying the location, scale and rotation, by pressing Ctrl + A $\endgroup$ – someonewithpc Aug 1 '14 at 8:12
  • $\begingroup$ Thanks for the reply. I tried that but that didn't work either. $\endgroup$ – Xeke - Hu Aug 1 '14 at 8:32
  • $\begingroup$ Of the mesh, not the bones $\endgroup$ – someonewithpc Aug 1 '14 at 8:43
  • $\begingroup$ yep that's what I did. $\endgroup$ – Xeke - Hu Aug 1 '14 at 8:53
  • $\begingroup$ Upload the blend then. $\endgroup$ – someonewithpc Aug 1 '14 at 8:56
1
$\begingroup$

everything is fine with the rig, but the Knee IK.L (pole target) bone is the child of some bone in the IK chain. If you parent it to main bone things look much better. If it still doesn't work, see the blend file attached ( http://www.pasteall.org/blend/41604 ).

$\endgroup$
  • $\begingroup$ Please use Blend-Exchange when sharing .blend files on this site. :) $\endgroup$ – Akados Apr 12 '18 at 23:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.