0
$\begingroup$

I have been working with maya for a very long time and just started with Blender so navigating is quite difficult for me. I checked online how to change the preferences and managed to get most of it except for 1, frame selected component (vertices,edges and faces). I have changed both the 'view selected' in preference with 'F' as the shortcut but that works only in object mode not in edit mode(thought that same shortcuts would work somehow:P) Is there anyway to apply both with 'F' so I have frame selected in object mode as well as edit mode?

$\endgroup$
  • 2
    $\begingroup$ I used Maya for around 10 years before switching to Blender. The best advice I can give is to leave the keymap alone for a while. It's often more convenient to customize stuff for yourself, and you should do that, however, one should do that after learning and being comfortable with the defaults. Other way you you are risking to miss out on a lot of intended workflows and amazing functionality. F key for example is used by F2 modelling add-on that is just amazing and a really powerful functionality to have. The keymap is complex - better get to know it first. $\endgroup$ – Martynas Žiemys Jul 22 at 5:17
  • $\begingroup$ Thanks for replying never knew I would get such quick to response, I am currently following a tutorial from blender guru and figuring stuff out.Once I understand the basics of things, I am sure eventually its gonna go as you say by working with the defaults since blender has a lot of useful shortcuts. $\endgroup$ – Suraj Nair PV Jul 27 at 6:56
1
$\begingroup$

The Problem is, that there is another Shortcut bound to F in that context, with a higher priority. In Blender there are context-bound shortcuts. You have changed the shortcut for the Object context. However, if you select a mesh and go into edit mode, you are in Mesh context.

In the Preferences, sort the shortcuts by Key-Binding and locate the Mesh section. Then remove or change the shortcut, which is currently bound to F, it will probably be Make Edge/Face. However, you will have to change the other shortcuts which are bound to F for each context individually.

user preferences

$\endgroup$
  • $\begingroup$ Just tried that out, Yikes!! there are so many shortcuts linked to F.Thanks a Lot. Sorry for the late reply. $\endgroup$ – Suraj Nair PV Jul 27 at 6:57
1
$\begingroup$

In Blender 2.8 you can choose the Industry Compatible keymap which already has your desired behavior by default.

You can change the keymap in Edit > Preferences

enter image description here

$\endgroup$
  • $\begingroup$ I tried this already then got stuck at the focus shortcut, I have currenty bound it to F in object mode and shift F in edit mode.Lets see how it turns out. Thank you for your response. $\endgroup$ – Suraj Nair PV Jul 27 at 7:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.