0
$\begingroup$

Edit: This post is not a duplicate to this question as I am using Blender Render, and not Cycles Render. Blender Render and Cycles seem to have very different options and work very differently. The answers to the the question this post may be a possible duplicate of do not help in Blender Render, only in Cycles.

Edit 2: Here's a link to a file with a letter, floor plane, camera, and lamp.

Nearly all my shadows in my render appear noisy/grainy, and I can't find anything that will fix it. I would like to note that I am using Blender Render and not Cycles Render. I've tried making the shadow samples for the lamp (which is a Spot lamp, although the lamp type doesn't seem to change anything) very high, but this did nothing. I've also tried turning up the soft size, using Constant QMC, toggling mipmaps, changing to Buffer Shadow instead of Ray Trace Shadow, and turning on/off World light settings. All of these either did nothing, or made the issue worse. I'm still a little amateur with Blender, so any and all help is appreciated! Thank you!

Also, here is some images. As seen in this first image, the un-rendered version, the shadows are completely fine.Shadows are not noisy.

In this image, which is a part of the rendered version, you can see that that the shadows are noisy. In the red rectangles, the shadows are very noisy.

$\endgroup$
  • $\begingroup$ Possible duplicate of How to avoid noisy renders in Cycles? $\endgroup$ – caleb lee Jul 21 at 21:17
  • $\begingroup$ Check out this link. blender.stackexchange.com/questions/4980/… $\endgroup$ – caleb lee Jul 21 at 21:17
  • $\begingroup$ @caleblee Please read my new edits. $\endgroup$ – hpenney2 Jul 21 at 21:24
  • $\begingroup$ This isn't an answer, but why not use cycles? The lightning is much more realistic and it should be easier to get rid of the noise. $\endgroup$ – caleb lee Jul 21 at 21:28
  • $\begingroup$ I don't use Cycles because I've always used Blender Render. Because of this, Blender Render is much easier to use for me and Cycles seems more complex. I'm not really looking for super realistic lighting anyways, just enough to make my render look okay. $\endgroup$ – hpenney2 Jul 21 at 21:32
1
$\begingroup$

If you want less noise, increase the Samples under Gather in the World settings of the properties panel.

The gather panel:

Samples
The number of rays used to detect if an object is occluded. Higher numbers of samples give smoother and more accurate results, at the expense of slower render times. The default value of 5 is usually good for previews. The actual number of rays shot out is the square of this number (i.e.Samples at 5 means 25 rays). Rays are shot at the hemisphere according to a random pattern (determined by the sample methods described above); this causes differences in the occlusion pattern of neighboring pixels unless the number of shot rays is big enough to produce good statistical data.

gather

$\endgroup$
  • $\begingroup$ Ahhh! Thank you sooo much!! This has been bugging me for days and all I needed to change was right in front of my face haha $\endgroup$ – hpenney2 Jul 22 at 6:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.