5
$\begingroup$

There are two objects in my 3D-view:

  • A red object

  • A white object

Both are overlapping each other.

I have added several keyframes of animation to the red object. When I select the white object, all keyframes disappear from timeline. They reappear if I select the red object again.

Why do keyframes disappear from the timeline?
What am I missing?

$\endgroup$
  • 1
    $\begingroup$ I think this is supposed to happen, the keyframes are hidden to keep the view clean.. $\endgroup$ – gandalf3 Aug 1 '14 at 1:28
7
$\begingroup$

This is a feature. You only see keyframes for the selected object in the timeline. If you want to see all your keyframes, I would use the Dope Sheet. enter image description here

The arrow icon only shows the key frame from the selected object.

The ghost icon shows keyframes form hidden objects.

The life saver :P(I think that the official name?) shows broken drivers.

$\endgroup$
5
$\begingroup$

This is how the timeline works:

The Timeline is not much of an editor, but more of a information and control window.

Here you can have an overview of the animation part of your scene What is the current time frame, either in frames or in seconds, where are the keyframes of the active object, the start and end frames of your animation, markers, etc...

Emphasis mine

If you want to see all the keyframes in the scene, use the dopesheet (ShiftF12). Click the ghost icon in the header to make keyframes on hidden objects visible:

enter image description here

$\endgroup$
  • $\begingroup$ does it again :-) that ghost icon was what I was looking for! $\endgroup$ – juFo Sep 12 '18 at 11:41
1
$\begingroup$

had the same issue.

the solution in my case was to disable Auto Keying: Editor Type > Timeline > click on the auto key button.

hope this helps

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.