2
$\begingroup$

Whenever I open a blend file that's from 2.79 in 2.8, all of the hidden objects from the blend file are grayed out but I can't unhide them. But other times layers from 2.79 that become collections are having the same problem of being grayed out even though they're not hidden in 2.79. Is this just a bug? I cant find an answer for it anywhere online. They do appear in the render, just not in the viewport window

$\endgroup$
4
$\begingroup$

When hiding an object in Blender 2.79 this is indicated by the eye icon in the outliner.

Outliner 2.79

In Blender 2.8x the eye icon has a different meaning. It indicates that the object is hidden in the current view layer (Hide in Viewport), whereas the option in 2.79 had a global effect. Hence, when loading an old file from 2.79, it is treated as Disable in Viewport (Monitor icon) instead. The difference between the two is explained in this answer.

The Hide in Viewport option is just applied for the current view layer, whereas Disable in Viewports is global and applies to all view layers and viewports.

In order to change the visibility for the hidden object you need to enable the setting to show the Restriction Toggles.

Restriction Toggles

Afterwards you can change the visibility in the outliner and the object will appear in the viewport(s) again. The effect of the restriction toggles is documented in Blender's manual.

Disable in Viewport

The same options exist for the collections as well. Additionally a collection can be excluded from the view layer by unticking the checkbox in front of its name.

More information about this topic is available on the following pages:

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.