6
$\begingroup$

I'm rendering an animation (as an .exr image sequence) and some images have these tiles appear on the final render. It somehow only happens on surfaces that are closer to the camera. It looks like Blender is somehow calculating adjacent tiles differently in certain areas.

You can see them on this image as the faint, slightly darker squares. The distribution of these boxes in random every render-iteration.

Has anyone had the same problem? I've tried turning denoising off, changing the tile sizes, changing the sampling or changing the light paths etc., nothing helped.

enter image description here

$\endgroup$
13
  • $\begingroup$ Hmm, this is quite weird. Have you tried any other file type? Does PNG and or JPEG work? $\endgroup$
    – Askejm
    Jul 19, 2019 at 19:44
  • 2
    $\begingroup$ Are you rendering on CPU or GPU? Try switching to just CPU to see if that helps. $\endgroup$ Jul 19, 2019 at 19:45
  • 1
    $\begingroup$ @RichSedman both. good thought... that may actually be the cause... different hardware, different output. although that does not explain, why those boxes only appear in this particular scene, where the camera gets closer to the terrain than in the others... (i'll try once my current render finishes) $\endgroup$
    – chribit
    Jul 19, 2019 at 22:29
  • $\begingroup$ jep, that actually was my first thought too. But nope, same problem with any other single-image filetype (didn't try the movie filetypes... shouldn't make a difference though). $\endgroup$
    – chribit
    Jul 19, 2019 at 22:31
  • $\begingroup$ I know this is going to be very general but could you explain more about your setup, if you are doing anything in the compositor, or if you are running any scripts or doing anything special $\endgroup$
    – Ben
    Jul 19, 2019 at 23:42

5 Answers 5

5
$\begingroup$

Figured out the cause thanks to @Rich Sedman, so I guess this is a temporary "solution", as it doesn't really solve the problem, just finds a way around it.

The tiles appear in the render due to CPU and GPU handling the output differently for some reason. Deactivating the CPU in the CUDA settings not only solved the issue but also gave me 30 seconds faster render times per frame.

Not sure if that's an issue of the current 2.8 release candidate or just something that comes with combining two pieces of hardware for the same process. (Maybe my Geforce GTX 1080 ti doesn't work well with my AMD Ryzen 7 2700X?)

$\endgroup$
1
  • $\begingroup$ If cpu and gpu produce different results then you should report it as a bug. $\endgroup$
    – sambler
    Jul 24, 2019 at 3:15
0
$\begingroup$

The opposite can happen too. My animation had bad tiles on three frames. I ran the frames over again with the exact same errors. Following the advice in this string, I turned ON CPU and GPU and bingo, problem solved.

$\endgroup$
0
$\begingroup$

Something quite similar has happen to me when rendering a complex scene on both CPU and GPU, but running only on GPU didn't solve the case. It wasn't darker squares that were appearing, but we could see transitions between tiles, a thing that generally is due to too tiny render tiles, but this time I tried with huge tiles, and the problem persisted. The only way I found to clean this was to set tile size to fill the entire screen.

$\endgroup$
2
  • $\begingroup$ You you have multiple graphics cards? $\endgroup$
    – David
    Apr 15, 2021 at 13:01
  • $\begingroup$ No. But I found the issue was due to OpenImageDenoise that sometimes works badly when rendering small tiles. $\endgroup$
    – BarryCap
    Apr 16, 2021 at 13:53
0
$\begingroup$

True! Problem solved disabling CPU from CUDA selection (Intel Core i5 9400F - Nvidia Asus ROG Strix 1060 6GB) and seems faster too! Not sure why, but not complaining lol

$\endgroup$
0
$\begingroup$

This constantly happens to me. I can't render on GPU only, since my GPU memory is too low. So it's either CPU only or completely unpredictable results. In some images, it works fine in "mixed" mode. Others look like Tetris gone wrong. Someone blamed the denoiser, but I also turned denoising off, same result.

A few samples are attached! Reflections on metal & glass

dark surfaces right, sofa left

without denoiser

with denoiser

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .