1
$\begingroup$

Blender 2.79b and 2.80 does not load unless I place the opengl32.dll file in the Blender directory. I've gone through all of the drivers I know to update but still no luck. Even placing the opengl32.dll file in the directory does not allow me to load previous .blend files.

Windows 10 Home
V 10.0.18362
i7-8750H CPU @ 2.20GHz, 2208 Mhz, 6 Core(s), 12 Logical Processor(s)
NVIDIA GeForce GTX 1050 Ti

Update on 7/19.
Went to Nvidia website (thank you) and downloaded the latest driver. Ran the blender_debug_gpu cmd from 2.80 with exactly the same result. The results:

Switching to fully guarded memory allocator.
Blender 2.80 (sub 74)
Build: Thu 07/11/2019 09:59 AM Windows 
argv[0] = blender
argv[1] = --debug
argv[2] = --python-expr
argv[3] = import bpy; bpy.ops.wm.sysinfo(filepath=r'C:\Users\xxxxx\AppData\Local\Temp\blender\debug_logs\blender_system_info.txt')
read file 
  Version 280 sub 39 date unknown hash unknown
Error   : Unrecognized Exception
Address : 0x00007FFC3FC7A839
Module  : C:\WINDOWS\System32\KERNELBASE.dll

This is a new computer so I'm almost to the point of returning it if I can get this figured out. Thanks for everyone's help.

$\endgroup$
11
  • $\begingroup$ are you trying to use a 32bit build? Try a 64bit one. $\endgroup$
    – Sazerac
    Jul 18 '19 at 1:59
  • $\begingroup$ Using 64-bit build Tried 32-bit with same result. $\endgroup$
    – Tom
    Jul 18 '19 at 2:03
  • $\begingroup$ Copying/Moving .dlls around is very, very wrong. When you say it doesn't run, are there any errors displayed? In the install directory of 2.8 you should find blender_debug_log.cmd. Please run this to create a debug log and add the results to your question. $\endgroup$
    – Robert Gützkow
    Jul 18 '19 at 9:31
  • 1
    $\begingroup$ Really appreciate the help @rjg. I figured out the problem. After running dxdiag it did not show any reference to my Nvidia graphics card. A couple of USB devices but that's it. Then it dawned on me that I am using a USB docking station so I can have multiple screens. For whatever reason, it wasn't accessing the graphics card. Once I unpugged the docking station I was able to start up Blender without any problem. I have used the docking station successfully in the past with other laptops so I'll have to sort through how to fix that. But Blender is working A-Ok! Thanks again for the help. $\endgroup$
    – Tom
    Jul 20 '19 at 12:07
  • 2
    $\begingroup$ And for future reference - the issue appears to be a Windows 10 bug. I had to Disable the onboard Intel graphics card to force Windows to use the NVidia card. This solved the problem: support.plugable.com/t/… $\endgroup$
    – Tom
    Jul 20 '19 at 13:03
0
$\begingroup$

I had the same problem. Here is how I solved it.

The PC has two graphics cards: one built-in Intel and one NVIDIA. By default, Windows (10-pro) recognizes and enables both. However, Blender default will work only with one of them. If you happen to use the other one instead, then Blender will close on start up.

Solution: Disable the graphics card which you are not using. Blender will go with the other one. It should work.

(Actually my experience is with Blender 2.90.1. Blender closes/crashes on loading/start up)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.