1
$\begingroup$

This question has been asked before but not properly addressed.

In the latest beta builds of Blender 2.8 including the release candidate, the shadow catcher is acting in an unexpected way in the rendered view in the viewport, blocking out the background image.

The screenshots below are from the same .blend file, opened first in blender 2.80.0-git.806d4fbc5e40 (3rd of June Release) and second in blender-2.80rc1-windows64 (the release candidate) I have also found the same effect appears in the 1st of July Release.

3rd of June Version

Release candidate 1

As you can see, in the later versions of Blender, using the same file, the shadow catcher object blocks out the background image, which is very undesirable behaviour and makes working with the shadow catcher very difficult.

Compositor nodes

The node setup is the default generated by the Motion Tracking area's Setup Tracking Scene, and the objects are in the correct collections. Transparent Film is also selected.

enter image description here

Despite the viewport not working the same way as before, the render still comes out correctly.

What has changed through these versions that causes Blender to act in this way? Is it a setting that I now have to turn on, is it a bug, or is it a deliberate feature? Because of the amount of motion tracking I do, I will have to continue using the outdated June version of 2.8 until this is resolved, though I would rather keep my version up to date.

$\endgroup$
  • $\begingroup$ Could this be the same issue reported in this ticket? developer.blender.org/T66777 and developer.blender.org/T65988 $\endgroup$ – rjg Jul 17 at 12:39
  • $\begingroup$ I believe it is related. I get the same effect when testing their method (turning off camera ray visibility for the cube), which does not happen in the June version. $\endgroup$ – Harry B Jul 17 at 12:57

protected by Community Sep 12 at 22:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.