0
$\begingroup$

The M button does not work and does not allow me to transfer the selected objects to the collection

enter image description here

If several objects are selected via lasso or box and not one object at a time using the Shift key, the M button does not work and does not allow transferring the selected objects to the collection or create a collection.

Dragging and dropping from one collection to another works well on any tests with new files, but with my level of some problems. Maybe some objects have invalid connections or properties.

$\endgroup$
2
  • 1
    $\begingroup$ have you tried the same thing while being in object mode and not in edit mode ? $\endgroup$ – Edmond Boulet-Gilly Jul 17 '19 at 9:20
  • $\begingroup$ @Edmond there are object origins of multiple objects shown on the screenshot which are displayed in Object mode $\endgroup$ – Mr Zak Jul 17 '19 at 10:13
2
$\begingroup$

You can't transfer because there is no active object.

Pasting objects also lasso/border selecting doesn't set any object as active, and most operators in Blender use active object as reference for settings, since there isn't one some operations may fail.

Solve this by Shift-clicking any of the selected objects so it is set as active without deselecting others.

enter image description here

$\endgroup$
1
  • $\begingroup$ Thank you. It was so easy to fix. $\endgroup$ – Morlok Ru Jul 17 '19 at 10:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.