0
$\begingroup$

I have this model of a truck and I'm setting up the bone structure for a UE4 vehicle project. The armature consists of six "wheel bones" and one root bone for all other parts.

I've manage to connect all meshes to corresponding bone besides my mesh called "additional lights". When I change pose, everything follows as intended but not this mesh (additional lights).

What have I missed?

enter image description here

$\endgroup$
5
  • $\begingroup$ Is this mesh parented to the bones? Are the vertices assigned to the root group? $\endgroup$
    – lemon
    Jul 17, 2019 at 8:38
  • $\begingroup$ The mesh is parented to the armature. I have then selected the vertices and assigned them to the root bone. $\endgroup$
    – Erik
    Jul 17, 2019 at 11:41
  • $\begingroup$ And thanks for the reply btw.. Here is a picture of the hierarchy: imgur.com/xpMC6zl $\endgroup$
    – Erik
    Jul 17, 2019 at 11:47
  • $\begingroup$ Except if filtered in the image in the comment above, I think 'additional lights' should have an armature modifier (some modifier visible in the outliner tree). $\endgroup$
    – lemon
    Jul 17, 2019 at 12:22
  • 1
    $\begingroup$ THANK YOU! Once I added the armature modifier to the light they followed the root bone. I've never had to add the modifier manually, but they have appeared in some magical way... Anyway, big thanks. $\endgroup$
    – Erik
    Jul 17, 2019 at 12:34

0

You must log in to answer this question.

Browse other questions tagged .