0
$\begingroup$

I must have hit some button, or typed a shortcut by accident, but my workflow has been shot in the foot by this problem. If I try to select multiple meshes and move them together by typing precise coordinates into the location section of the transform, only the mesh which was selected last moves. I've also lost the ability to deselect all using the "A" key, so there is always at least one mesh selected. I tried to restore blender's default settings but the problem persisted.

Here's a visual representation of what I'm dealing with: two cubes are selected and positioned right of the origin. Only the coordinates of the most recently selected cube are visible, not an average.

For example, normally if I wanted to move both of these cubes so they were evenly placed on either side of the origin, I could just type "0" into the X coordinate and both cubes would move together. One cube is positioned on the origin, the other is intersecting with it, to the right

Now, however doing this results in only one mesh moving. Strangely, if I try to select meshes at the same time using circle select or border select, there is still one mesh that seems to be dominant. Also, if I had another mesh selected, and then try to border select several other meshes, not including the first one, that first mesh remains "selected" and will be the only one that moves, even though other meshes are actually selected.

There are four cubes. Three are selected, and one is not selected, but still has a marker showing its origin, and will move when coordinates are entered.

I have some long-winded work-arounds that I can use for the time being, but this is really slowing me down in a very inconvenient way. If I can't figure out what to do, I'm going to have to try reinstalling blender.

$\endgroup$
  • 1
    $\begingroup$ well it seems to me that what you describe is the normal way of working in Blender, maybe you confuse Object mode with Edit mode? $\endgroup$ – moonboots Jul 17 '19 at 4:20
  • $\begingroup$ I can't rule out the possibility that's what going on. It may be that I got really used to working with joined meshes or something. I could've sworn that it worked differently earlier today though. $\endgroup$ – HAMonWRY Jul 17 '19 at 4:56
  • $\begingroup$ In 2.8 you can select 2 objects, go in Edit mode, and edit both the 2 meshes, it was not yet possible in 2.79 $\endgroup$ – moonboots Jul 17 '19 at 4:58
  • $\begingroup$ I would say, instead of using the property editor, which only edits the one active objects values, using numeric input which wil move all selected objects the same amount. $\endgroup$ – sambler Jul 23 '19 at 10:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.