I don't really know what went wrong. At all. I'm very new to this.

What I did: High-res is being baked into low-res with everything exploded. One on top of the other. Low-res and hi-res are overlapping. But it looks completely abnormal, especially when exported into something like 3D Coat where everything is pixelated. There are artifacts all over the place, which indicates that something is being done wrong in Blender when it comes to baking. Note that the artifacts are there because the normal values are right on top of different parts of the mesh (I don't really understand why this happened). The last two images show that it's not right. Here's what it looks like:

enter image description here And if exported to 3D Coat with this map, we get this: enter image description here enter image description here

enter image description here

Anyone have any idea what I'm missing here? Take a look at the last two images. The texture map looks all messed up in 3D Coat (the blue and purple map). Even though it's 2048x2048, it looks like pixelated nonsense. Is it related to UV unwrapping? Painting, also, makes it pixelated as well. Any help is greatly appreciated!

  • $\begingroup$ 3D Coat might flip the green channel (or interpret it as flipped). Besides that your normal map doesn't look very smooth. You may need to increase the baking distance or create a cage object for better quality bakes. $\endgroup$ – rjg Jul 16 at 20:58
  • $\begingroup$ For green channel, yes, it was flipped. I unflipped it, and it didn't help. The cage object already exists, which is identical to the LowResBake object. As for baking distance, I will try that. I thought it's already pretty good (it's at 0.05m). Edit: I upped the distance to 0.2m. It seems to eliminate some artifacts, but not all. Some artifacts are worse. What can be done about the rest? Is it because the cage is too small? The normal map looks the same: problematic in 3D Coat. $\endgroup$ – Lucidity of Power Jul 16 at 21:05
  • $\begingroup$ The quality of the mesh and 3D Coat's problem may not be related. Unfortunately I'm not familiar with 3D Coat, so I can't tell if there are some settings that could be causing this. The only thing I can think of (if it's not the green channel) would be value clamping because you stored the normal map as full float .hdr/.exr or 16 bit .tiff in Blender (which 3D Coat may not support). $\endgroup$ – rjg Jul 16 at 21:22
  • $\begingroup$ But the normal map looks right? The baked image itself is just a .png. $\endgroup$ – Lucidity of Power Jul 16 at 21:32
  • $\begingroup$ Ok, I think it's worth mentioning that the leather straps, when removed, give a normal UV map that's usable and everything looks fine, even in 3D Coat with the maps. But I can't understand why they're the problem...?? $\endgroup$ – Lucidity of Power Jul 16 at 21:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.