1
$\begingroup$

So I have made a fairly simple shape (I'm new to blender) that I created using the mirror modifier on the X and Z axis so I only needed to make one quarter of it and the rest was mirrored. It's something I'm wanting to 3D print, so I had to make sure it was properly structured (my previous attempt had appeared in the slicer as... a complete mess.)

Everything works fine, everything is accurate. I use the 3D toolbox to check for errors, and with the mirror modifier still on the queue there's 0 non-manifolds. As soon as I apply the modifier, it changes to 40 non manifolds.

Ok that's fine, it seems to be where the mirrored objects meet. I had Merge selected on the mirror options, but it seems to do nothing. Whatever, no problem. The solution is to Remove Doubles, right? (Going from previous help topics on stack)

2.8 doesn't have Remove Doubles.

Ok so the new version of remove doubles is merge by distance. Select all the non-manifold vertices, merge by distance. Removes 0 vertices. OK maybe increase the distance a little? Nope.

It only removes vertices when I hit 5mm, which happens to be the next row of edges (which it promptly gobbles up). So as far as the merge by distance tool is concerned, I have no non-manifold doubled up edges/verts in the shape. But the 3D Toolkit is determined that I have 40 of them.

I could just select and delete them... but I'm not sure if that's fixing things or breaking them futher. But as this seems to be a question that hasn't been asked yet (since the update changed how things worked) I figured it was appropriate to ask it!

Hopefully someone can help.

$\endgroup$
  • $\begingroup$ Could be inner faces. Adding some image of what you are doing could help. $\endgroup$ – lemon Jul 16 at 7:47
0
$\begingroup$

Select all vertices in your mesh and hit Alt-M. From the drop-down, choose "By Distance". You can also change the "distance" at the bottom-left corner of the window. Here's a picture to show you where.

mergeDistance

It looks to me like this is pretty much the same as the "Remove Doubles" option. Hope this helps!

P.S. If you have two vertices that are not at the same position, and you want them to merge to the position of a certain one of those vertices, you select the vertex that has the desired position first, then select the other and merge them, using the drop-down option "At First". Hope that makes sense.

$\endgroup$
  • $\begingroup$ Sorry, you might want to re-read my description lol. Merge by distance doesn't work. It does nothing, unless I increase it past 5mm when it starts to eat up the adjacent lines. The faces down the mirror line remain. $\endgroup$ – nirurin Jul 16 at 1:53
  • $\begingroup$ Oh, oops! Sorry about that. It's kinda weird that that happens. Could you upload your blend file? $\endgroup$ – RBlong2us Jul 16 at 2:21
  • $\begingroup$ I actually now can't, because I fixed the problem by going into mesh mode, finding the internal faces, and deleting them all manually. Which was a pain lol. I assumed that there would be a better way, but I failed to find it. $\endgroup$ – nirurin Jul 16 at 3:08
  • $\begingroup$ I can easily duplicate the problem - just make a shape using a mirror in 2.8. I had the 'merge' option on, which may have been the problem? I believe it merges vertices, which may explain why there was no doubles, but it fails to delete internal faces so it still ends up non-manifold. At least, that's what it seems like, but I'm no expert I may be making it all up. $\endgroup$ – nirurin Jul 16 at 3:15
  • $\begingroup$ Yeah, that sounds like the answer alright. Good job figuring out the problem! $\endgroup$ – RBlong2us Jul 16 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.