4
$\begingroup$

The dropdown menu to select the render engine (e.g. "Cycles", "Blender Internal", "Blender Game") isn't showing up:

render engine dropdown missing

I compiled Blender myself (SVN r56975), and although I've enabled WITH_CYCLES with CMake at compile time, the Cycles addon warns about missing script files. But the "Blender Game" option should still be there.

$\endgroup$
  • $\begingroup$ you could try running "blender -b -E help" in the command line to list available render engines.. maybe blender game wasn't enabled? $\endgroup$ – gandalf3 Jun 28 '13 at 2:08
  • $\begingroup$ Only BLENDER_RENDER but I configured CMake with WITH_GAMEENGINE and WITH_CYCLES. I don't know why they're not there. Also, why would this happen? They should both be working. $\endgroup$ – Forest Katsch Jun 28 '13 at 2:15
  • $\begingroup$ I don't know, though this bug report looks related: projects.blender.org/tracker/… $\endgroup$ – gandalf3 Jun 28 '13 at 2:20
  • $\begingroup$ I've never had this problem on this computer (or on any computer I've used Blender on), which is strange. I just did svn up and rebuilt it. $\endgroup$ – Forest Katsch Jun 28 '13 at 2:31
  • 4
    $\begingroup$ Building blender is not topic for the site $\endgroup$ – ideasman42 Jun 28 '13 at 4:20
7
$\begingroup$

Short version:

  1. check first a build from builder.blender.org
  2. then
    • verify source modifications
    • verify build settings
  3. fix your modifications or build settings.

When you see weird behavior in own builds for which you also have changed source always check a build from builder.blender.org . If the unexpected behavior doesn't show up with such a nightly test-build, then you should review your modifications and build settings as they are apparently the cause for the behavior.

For building settings and troubleshooting of builds, refer to the build instructions for your own platform and build system. There are trouble shoot sections for each way.

If on the other hand the unexpected behavior is replicable with such a build, then you likely have found a bug, at which point you should be reporting that to projects.blender.org

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.