2
$\begingroup$

I'm trying to use the number pad shortcuts to control the views, Left, Right, Back, etc. It isn't working, though. It only works when I click on the view through the menu. viewport

Instead, these little boxes are lighting up.
layers

How can I make it so that my Number Pad keys will have the desired effect?

$\endgroup$
1
$\begingroup$

Try checking Emulate Numpad in the User Preferences(Ctrl-Alt-U).

enter image description here

$\endgroup$
  • $\begingroup$ Awesome! And just for curiosity, is this only necessary on desktops? $\endgroup$ – user3758041 Jul 29 '14 at 21:33
  • $\begingroup$ If this helped you, please mark it as accepted(that gray check mark under the voting buttons.). No, this is not only necessary for desktops, it's used for laptops too. Also, not all desktops require this, mine doesn't. $\endgroup$ – GiantCowFilms Jul 29 '14 at 21:41
  • 2
    $\begingroup$ It's actually quite strange this is necessary in your case, and that it even worked. This option normally makes it so the number row above the main keyboard can be used instead of a numpad (at the cost of some shortcuts which use those numbers, e.g. layer switching or subserf), but I guess not in this case..? $\endgroup$ – gandalf3 Jul 30 '14 at 10:36
  • $\begingroup$ @gandalf3 my best bet is their is an issue in the keyboard drivers, or some compatibility issue. $\endgroup$ – GiantCowFilms Jul 30 '14 at 14:21
  • 1
    $\begingroup$ Try pressing the NUM_LOCK button on your keyboard number pad. Number pads have two modes and that button switches between them, at least for Windows that's how it is. That button seems to have no effect under OSX and I'm not sure what happens with Linux. $\endgroup$ – MarcClintDion Aug 31 '14 at 3:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.