8
$\begingroup$

I've been working with the VSE for a while and everything was fine. But all of the sudden, when I play the preview the sound doesn't play. I think I must've disabled it somewhere, but I can't manage to find the place. It doesn't matter if I start a new project, sound doesn't play so I think it must be some kind of configuration. Does anyone know what could have happened? (Computer's sound is working fine)

EDIT: I have found this thread. I'm running Blender on Debian 7.0 unstable, and maybe an update has messed my setup. Thing is that any other app works fine, music player, vlc, games, the only one that does not work is Blender, but as the link suggests it could be a setup problem not having to do with Blender. I'll do my homework and come back if I can manage to find a solution to post it here.

$\endgroup$
  • $\begingroup$ Can you post your .blend. I would say screen shots but I don't think that would be enough. $\endgroup$ – GiantCowFilms Jul 29 '14 at 20:42
  • $\begingroup$ I'm afraid I don't know how to upload a blend file, I can only see an icon to upload pictures. Anyway, I don't think it will be of any use, since starting a new project will give the same results, I can insert a new audio strip but when I hit play no sound is played. I can upload screenshots of user preferences if it can help just tell me if you want a specific configuration page or all of them. $\endgroup$ – YoMismo Jul 29 '14 at 20:47
  • $\begingroup$ What happens if you pick a different sound backend in User preferences > System > Sound? $\endgroup$ – gandalf3 Jul 29 '14 at 20:55
  • $\begingroup$ I have tried both options SDL and OpenAL but with no use. $\endgroup$ – YoMismo Jul 29 '14 at 20:57
  • $\begingroup$ @YoMismo Upload it to dropbox, then link to it. $\endgroup$ – GiantCowFilms Jul 29 '14 at 21:07
5
$\begingroup$

I can think of a couple possibilities:

  • Your audio track is muted in the VSE

    Select the track

    hit n

    deselect the 'eye' button

    VSE track settings

  • Your sequence is no longer pointing to the audio file because you've moved it or the blend

    repath the file using the 'file location' tool button shown in the above image

  • Your scene volume is set to 0

    goto the Scene tab in the Properties frame

    expand the Audio panel

    adjust the volume or other settings

    enter image description here

$\endgroup$
  • $\begingroup$ First of all thank you for taking the time to answer. Audio is not muted, at least not with the eye icon, I have tried to set/remove a couple of times with no use. File path is ok, since audio playback fails even with a new project and opening a new audio file, so that shouldn't be the case. Volume doesn't seem to be the problem either, since I have tried raising it to the top and no sound is played either (The sound file plays correctly from outside Blender so audio source file is OK). $\endgroup$ – YoMismo Jul 30 '14 at 15:50
  • $\begingroup$ One thing I have to check as soon as I get home is the last image, I didn't know there was a volume in the scene section, I have raised the volume in the VSE strips, but I didn't know about the one in this section. As soon as I test this I'll post the result. Thanks again for your time. $\endgroup$ – YoMismo Jul 30 '14 at 15:51
  • $\begingroup$ No luck. I've checked the volume in the scene section and it was already at 1 which is the highest value, but no sound is playing :-( $\endgroup$ – YoMismo Jul 30 '14 at 18:58
  • $\begingroup$ I'm unable to post an answer, so I'll just suggest that this answer be updated to mention a solution that worked for me: restarting Blender. $\endgroup$ – Nathan Wailes Dec 31 '17 at 12:51
4
$\begingroup$

Ok I found the problem and the solution.

As the link I posted in the edited question suggested, the problem was some twisted setup, the last update should have messed something.

What I have done has been.

  1. First I moved my $HOME/.pulse to $HOME/.pulse_old to start with a new setup.
  2. I launched pavucontrol
  3. Switched to setup tab.
  4. Select my sound output device.

BINGO!!! now Blender VSE plays sounds again.

Thanks to everyone who tried to help.

EDIT:

This finally turned out not to be a Blender problem (eventhough I am not that sure, since it was the only program failing). Nevertheless, I am posting the solution since someone might benefit from it in the future.

$\endgroup$
4
$\begingroup$

I have done this by:

  1. Select Render Properties
  2. Go Down Expand Enconding
  3. On Audio Codec:
  4. Choose dropdown from None to MP3

a busy cat

Now you can hear the sound, cheers!

$\endgroup$
  • $\begingroup$ Wrong advice? How do you know it was wrong advice? The problem appeared and was solved without modifying a bit of the .blend file. The problem was solved (read the above answer marked as solved) just reconstructing pulse audio's configuration directory... $\endgroup$ – YoMismo May 4 '15 at 14:59
  • $\begingroup$ well i'm using pavucontrol but there's no setup tab , only configuration tab, and there's no option "Select my sound output device.". I'm Using Xubuntu 15.04 $\endgroup$ – haidarvm May 5 '15 at 13:59
0
$\begingroup$

I had the same problem and then I realized I had moved the original audio files somewhere else. This is a common problem with Blender so you must always make sure to keep your files in a project-related folder

$\endgroup$

protected by cegaton May 2 '16 at 14:00

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.