0
$\begingroup$

I took a humanoid mesh off the internet to use as a character model. I also have a custom humanoid skeleton. I lined up the skeleton to the mesh, then I parented the mesh to the bones. The rig looks fine, except for some leftover vertices that are exactly from:

  1. The character's eyeballs/eyelashes
  2. The character's lips
  3. Some buttons on the character's jacket

These vertices stay in place while the rest of the mesh poses perfectly fine.

As far as I know, the humanoid mesh is 1 Blender "object" - the same mesh. So I'm surprised that those specific vertices aren't weighing to any bone at all. Any ideas as to why these very specific pieces of the mesh aren't parenting? I tried cleaning the mesh up with Remove Doubles for vertices, but that didn't fix my problem.

Thanks in advance.

$\endgroup$
1
$\begingroup$

You often need to make some corrections once you've parented, typically with independent meshes like eyes, button, etc...

The classic way to fix this is to switch your armature to Pose mode and switch your object to Weight Paint mode then to select the bone to which you want to assign the button/eye, and paint this zone with the brush. Don't forget to deactivate the Limit Selection To Visible option, button on the right of the header menu.

enter image description here

You can also assign the vertices you want to the vertex group they are supposed to be part of in the Properties panel > Data > Vertex Group... When you've parented With Automatic Weights it has automatically created vertex groups and given them the name of the bone that controls them. If you want to add some vertices to a group, select those vertices in your mesh, select the group in the list and press the Assign button.

enter image description here

$\endgroup$
  • $\begingroup$ Thank you! With the weight painting outlining, I also realized that some of the buttons were just mapped to the wrong bones. I was able to subtract and clean up those meshes too. Thanks for the quick and concise answer. $\endgroup$ – user76603 Jul 12 at 2:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.