0
$\begingroup$

Keyframe

This is something annoying because it always happens at some point, since I know Blender in version 2.5x I have always wondered how to delete those keyframes that are lost and do not appear or are assigned to any object or value or constant of your blend file, and that you never find and although they seem harmless they always end up causing you problems to export your model to some other game engine platform.

Any suggestion of how to erase these keyframes? Some script or something in the file that you should delete???

empty.blend download

$\endgroup$
  • $\begingroup$ Have you tried the Outliner? Press the plus sign at the left of the object's strip to see the 'Animation' strip. Right click on that and select "Clear Animation". If that doesn't do it, save the project, exit Blender, delete any cache folder/files you see in both the project folder, or Blender's Temp folder. Fire up Blender again. Also check you're not using baked animation somehow. Could the object be linked to another somewhere? Right click the Outliner strip and "Unlink". $\endgroup$ – Edgel3D Jul 10 at 3:22
  • $\begingroup$ no, none of that works, since blender use has always had that problem at some point fuck your file with that frame and you never find a way to eliminate it, in blender development they never tell you how to analyze the file from outside or externally to search the problem and there is no relative information here, and here the administrators are annoyed and it rots the soul that you ask things related to the source code and you start being harassed $\endgroup$ – Blender Blackened Jul 10 at 17:36
  • $\begingroup$ I'm not new to blender enough, if you want to solve it with your suggestions here at the end of the post is the file, $\endgroup$ – Blender Blackened Jul 10 at 17:38
  • $\begingroup$ I tried that link and ended up on a Google page for first aid kits!. Nothing downloaded either. I use Vers 2.77a because it's stable and in my opinion, downright fantastic - usable and predictable - better the devil you know :) I appreciate your frustration - I've encountered similar in earlier versions and it's taken some time to eliminate or work around these glitches. Most often it's something I've done. $\endgroup$ – Edgel3D Jul 11 at 3:23
  • $\begingroup$ @Edgel3D sorry in the original edition erre the syntax of the link, try now and you can download it $\endgroup$ – Blender Blackened Jul 11 at 4:35
1
$\begingroup$

I got rid of it but using vers 2.77a. Let's hope it works in your version...

-===============-

The problem was a grease pencil hangover and it's slot that was still active.

Procedure to rid yourself of that pesky keyframe...

Zoom in a bit to see the G/pencil drawing south of the grid.

Goto Edit mode and press A. The GP points will all hilight

Delete them with X. (points)

Press N to open the 3D viewport's properties and delete the Grease Pencil slot.

Untick the grease pencil's box.

The keyframe will still be there.

Save the file as something else and the keyframe should disappear when the 3D widow updates.

If not exit Blender and reload.

$\endgroup$
  • $\begingroup$ and to think that in blender they must have told me to change to 2.8 ajajaja I appreciate the suggestion but to my 2.8 I do not like it or I contemplate it as an option it is scare ehe unstable $\endgroup$ – Blender Blackened Jul 11 at 13:05
  • $\begingroup$ Thank you very much $\endgroup$ – Blender Blackened Jul 11 at 13:09
  • $\begingroup$ No problems mate - Happy Blending... $\endgroup$ – Edgel3D Jul 11 at 22:44
1
$\begingroup$

this might work for you in the python console..it loops through every keyframe in the scene and deletes them..

import bpy
for a in bpy.data.actions:
    bpy.data.actions.remove(a)
$\endgroup$
  • 1
    $\begingroup$ this works to eliminate lost frames of a very large scene that I had abandoned, it did not occur to me to use peiton jajajaa now more than the solution you reminded me so that it has integrated that ugly pseudo language called python, my programming language is c, c ++ c # y others of high level, I try not to contaminate myself with python but because sometimes it is useful although I do not like $\endgroup$ – Blender Blackened Jul 11 at 13:08
  • $\begingroup$ Thank you very much $\endgroup$ – Blender Blackened Jul 11 at 13:09
  • $\begingroup$ I actually tried this in the attached .blend file and it didn't seem to work, but will leave it incase others find it useful... similar to Edgel3D's answer, I was able to delete the keyframe by going into edit mode then hitting A, and clicking "Delete All Active Frames" $\endgroup$ – Derek Eden Jul 11 at 13:22
  • 1
    $\begingroup$ grace pencil does not give problems, the problem is in how blender joined it to itself, and never make a debug worthy of respect and these errors of novice programmer of people who are supposed to participate in code quest u code summer are quite criticizable but that bothers you, read this developer.blender.org/T66634 $\endgroup$ – Blender Blackened Jul 11 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.