39
$\begingroup$

I want to lock objects from getting selected, but not change their visibility.

2.8 removed the lock button from the outliner. How do you lock objects in 2.8?

$\endgroup$

2 Answers 2

36
$\begingroup$

Did you check the option in outline panel?

$\endgroup$
2
  • 10
    $\begingroup$ For anyone else who reads this and still can't get it to work, see the animation in the answer below. $\endgroup$
    – N. Virgo
    Jul 19, 2020 at 4:48
  • $\begingroup$ Yeah this hardly answers the question, it "answers" it with another question. $\endgroup$
    – arkon
    Jan 4 at 6:07
71
$\begingroup$

The option to make objects not selectable still exists. On the top of the outliner window look for a filter icon (looks like a funnel). Click on it and you will have access to other restriction toggle switches for the objects in the outliner.

enter image description here

$\endgroup$
2
  • 1
    $\begingroup$ Now it's so obvious, thank you! $\endgroup$ Sep 2, 2022 at 20:43
  • $\begingroup$ Works fine on Blender 2.9, just scale the outliner menu to the left and you will find it $\endgroup$
    – Sarah
    Sep 24, 2022 at 7:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .