1
$\begingroup$

I am trying to render a complex object (suppose this is a torus). The area occupied by the object itself is much smaller than the area of the object bounding rectangle. I only need to render this object.

The surrounding scene is not important to me (besides its effect on the object lighting). I try to adjust the object material and I often have to rerender the scene.

It takes a lot of time, so I want to throw out the rendering of all the excess. I know about rendering boundaries, but this only works for a rectangular area, which is not effective for a torus. Can I somehow define the rendering area including only interesting object?

My guess how I could do it:

  1. Disable some tiles during rendering.
  2. Determine the non-standard ray density distribution for tracing.

Unfortunately, I did not find the standard functions and plugins for this. Maybe someone has already solved a similar problem and knows the solution.

$\endgroup$
  • 1
    $\begingroup$ If you are tweaking materials you can try only rendering small patches of the torus or low resolution and then deciding whether to go for a bigger render or not. Your point 2 is effectively adaptive sampling, where the renderer detects more complicated areas to get more ray samples. Tthere is currently a patch in progress, but it isn't in blender yet: developer.blender.org/D4686 $\endgroup$ – Sazerac Jul 8 at 5:04
  • $\begingroup$ Is it possible to turn off other objects from rendering entirely, or do you need them for their indirect contribution to the object's shading? That is, could you turn the rest of the scene (except lights) and not lose much? Alternatively, could you bake the rest of the scene somehow and then turn them off? $\endgroup$ – Ben Jul 8 at 13:02
2
$\begingroup$

You could put your model on a renderlayer and then model a plane with a custom shape hole on another layer and then tick exclude and mask for that layer on the model-layer.

$\endgroup$
  • $\begingroup$ He can just use the original object as a making object, right? $\endgroup$ – Leander Jul 8 at 14:03
  • $\begingroup$ It is a pity that the blender does not have control functions for the trace zones, but the layers can partially solve the problem. $\endgroup$ – Dmytro Dadyka Jul 10 at 2:06
0
$\begingroup$

EDIT: All of this is surely possible in 2.8, but I haven't really used it yet so I'm not sure about where to find all these settings.

If you're using 2.79, you could restrict rendering on all objects in your scene you don't want to be rendered. This can be done by unchecking the camera icon of the object you want to restrict rendering on. It should look something like this:

Blender 2.79 outliner with partially restricted rendering

So in this case, the cubes are getting rendered, but the planes aren't. They still affect the movement of some objects in my scene though, since I'm using cubes to bounce off of the planes, but I don't want the plains to be visible.

Also, try turning off your background by opening the film tab under render options and tick the 'transparent' box. Make sure you've set your output data to PNG, so the final render will have a transparent background.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.