2
$\begingroup$

So I am using Blender 2.8, and I cannot seem to get the Ambient Occlusion node to work in EEVEE. I realize it is in beta, so it could just be a bug in 2.8, but I have seen other people use ambient occlusion in eevee (like here), so that leads me to believe it is not an issue with 2.8.

Below is a model with an ambient occlusion shader attached in Cycles, and it works as expected: in Cylces

However, when I use the same setup in EEVEE, it doesn't work, and the ambient occlusion node outputs the same color across the entire model, making it show up as completely flat: broken one in EEVEE

Is there something I am doing wrong with the ambient occlusion node to cause this to happen?

Thanks in advance.

$\endgroup$
  • 1
    $\begingroup$ You have to enable AO in Eevee render settings. See the render tab in your second screenshot. $\endgroup$ – sacrish Jul 8 at 2:21
  • $\begingroup$ Oh thanks, that was dumb of me. $\endgroup$ – person132 Jul 8 at 4:56
2
$\begingroup$

As @sacrish said, I had just forgotten to enable Ambient Occlusion in the render settings, causing it to not work.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.