2
$\begingroup$

Hello Blender Community!

I am currently learning with Blender 2.71 and use Unreal Engine 4.

I started to create a Knife, but I always have problems exporting it. I tried to recalculate normals with CtrlN but it still cut off.

Here are some screenshots:

BLender Unreal Engine

Blender

Exporting Options

$\endgroup$
  • $\begingroup$ the shortcut to recalculate normals is Ctrl N, not Ctrl A. $\endgroup$ – gandalf3 Jul 28 '14 at 23:16
  • $\begingroup$ Could you add a screenshot showing the topology? You might have ngons or something. $\endgroup$ – gandalf3 Jul 28 '14 at 23:21
  • $\begingroup$ @gandalf3 i'm sorry but what do you mean with topology and ngons? top ortho? $\endgroup$ – skyraider_x3 Jul 28 '14 at 23:25
  • $\begingroup$ In edit mode, so that you can see the edges and faces $\endgroup$ – gandalf3 Jul 28 '14 at 23:47
  • $\begingroup$ @gandalf3 ok included it $\endgroup$ – skyraider_x3 Jul 29 '14 at 0:08
3
$\begingroup$

I cannot be certain of what is wrong without a .blend. my best guess is that your issue is caused by NGons. NGons are faces with more the four edges.

to remove them, select the faces that are Ngons

(Spacebar>Select Faces by Sides>set number of vertices to grater that 4 and type to greater than)

then delete them useing X>Only Faces. then use Alt-F, then Alt-J.

| improve this answer | |
$\endgroup$
3
$\begingroup$

The faces on the sides of the knife seem to be N-gons.

Try triangulating the mesh before exporting it:

  1. In edit mode (Tab), select everything (A) or just the ngons by pressing 3D view > Header > Select > Faces by sides, then setting the type to greater than in the redo panel (F6):

    enter image description here

  2. Triangulate the faces by pressing CtrlT:

    enter image description here

If you want more control over the triangulation, you might try using the triangulate modifier.

| improve this answer | |
$\endgroup$
0
$\begingroup$

Tris and Quads are fine but N-gons create this issue in unity when it can't decide how to tesellate.

Removing n-gons did the job for me

To remove n-gons just add an extra edge to divide them into quads and tris for the faces where you are facing the problem; if you cant afford more UVs and tris. Otherwise go with the processes as mentioned above

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.