0
$\begingroup$

As stated, the textures do not follow the settings in the material. They seem to repeat no matter what while in material mode of the 3d-view, but render fine. Nothing in the material seems to change this. Any solution? It's not a deal breaker but it'd be more convenient if I could resolve it. This occurs on all my models, this is not a special case. Using 2.79.

In the below screenshot I am using Extend instead of repeat but this is only reflected in render.

enter image description here

EDIT: Apparently this is an 7-8 year old bug that's only fixed in 2.8?

$\endgroup$
1
$\begingroup$

You can do it with math so it's shown in the 3D view as well if you must:

enter image description here

It seems it gets a bit confusing on exact 0 and 1 on the coordinates as you can see at the edges, but if we extend the last 0.5% or so of the image it seems to work fine:

enter image description here

| improve this answer | |
$\endgroup$
-1
$\begingroup$

An alternative solution here, strangely they added the clamping options in 2.76 but those never worked in cycles material mode, and rather the workarounds people used before those options existed work perfectly.

enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.