0
$\begingroup$

I am modeling a car wheel in Blender 2.79 right now. I am combining the outer edge of the wheel with the spokes. I did this by:

1.) Joining both objects.

2.) Making edge loops on the outer edge piece which line up with z-values of vertices on the spokes, and snapping the vertices of the spokes to vertices on these edge loops.

3.) Making sure the faces / edges all line up right and flow right (They do, Blender recognizes the edge of the spoke and the edge of the wheel rim as one edge loop, which is good).

My model is pretty low-poly, but I have a Level 2 Subdivision Surface modifier applied on my spokes/rim object, and a few edges are creased. I wanted to join these two objects for this reason: where the end of the spoke meets the rim, it should look smooth and should have an edge which catches light (to look/be realistic).

I also have a Mirror Modifier on the spokes/rim with Merge Vertices turned on, and an array of 10 spokes/segments of the rim which makes the whole 10-spoke wheel (Also with Merge Vertices turned on).

Here is what my model looks like with Subsurface and Smooth Shading turned off.

enter image description here

Here is the issue: When viewing my object with the subsurface turned on, there are some weird polygons at the top and bottom of where the spoke meets the rim. As you can see, the vertex is pushed outward by the modifier and just doesn't shade right. There aren't any n-gons or anything, as seen in the previous .gif.

enter image description here

So - What is causing this anomaly? What can be done to fix it? It's probably something obvious that I just am not noticing, like putting an loop cut somewhere or something like that. Thank you so much!

$\endgroup$
0
$\begingroup$

It looks like you have the setting "show modifier geometry in edit mode" activated for the subsurface modifier... Its one of the visibility options in the modifier settings. I assume this because you appear to have some curved edges, which should otherwise be impossible. If you turn this setting off again, then the subdivision modifier will behave normally. So no controller-mesh change for edit mode view, yet if you keep the setting "modifier visible" on, you will still be able to see how the mesh is influenced by your controller-mesh changes from edit mode, without the edge problems you currently have.

$\endgroup$
  • $\begingroup$ I'm aware that I have the modifier visible in edit mode. I was using it to point out that the modifier is creating faces that are stretched and don't shade well. Thank you for responding. $\endgroup$ – Philip KP Jul 8 at 13:10
0
$\begingroup$

These polygons are created by the nature of how subsurf works.

You can fix this by putting on more subdivisions and setting the shading to Smooth on the Transform tab to the left .

Access the Transform tab by pressing T.

$\endgroup$
0
$\begingroup$

I found it tricky to work out as it keeps moving :) From what I can see you have a pole (6 edges) at the top and bottom of the connecting strut. You will need to move this away from the edge and probably surround it with a loop so it does not cause issues with the rest of the mesh. Possibly have a few static shots?

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.