2
$\begingroup$

I'm a student and this is my first experience with blender so I'm not an expert. I'm facing a problem when I try to bake normals in tangent space.

hippo.blend DOWNLOAD

I have two meshes representing an Hippo, created following some tutorials on youtube. One is high poly, second is low poly. enter image description here enter image description here

I'm using blender render, as in the tutorials. I'm able to create an uv map unwrapping the low poly mesh and to do the first bake (select low poly mesh and click bake in render menu). enter image description here

It is one day that I'm trying the final step of the tutorial in which I open my uv map in the uv editor, select in bake options "selection to active", I select the high poly mesh, shif+select low poly mesh and I click bake again. I can see that blender do the bake but the result does not change in any way. enter image description here

I found the tutorials on youtube typing "Hippo Blender". They are five and I followed everything. But between the video 4 and video 5, I put bones and two animation on my model (not done in the original tutorial). Then I started again with the last tutorial.

I'm using blender 2.79b in the tutorial it is used blender 2.6 I think. I try to read all the related topics in this forum but I'm not able to find a solution.

If someone can help me I can share the blender project

Thank you in advance

I edit the question after the answers adding some images of the current settings and the normals that I can see.

enter image description here enter image description here enter image description here enter image description here enter image description here as you can see my uv map never changes.

$\endgroup$
10
  • $\begingroup$ Which mesh are you selecting first? $\endgroup$ – user58715 Jul 7 '19 at 16:14
  • $\begingroup$ because and for what purpose you have activated the FREESTYLE box ??? $\endgroup$ – user58715 Jul 7 '19 at 16:20
  • $\begingroup$ the 2.6 blender tutorial also applies for 2.79b, you can also do normal in cycles 2.79b $\endgroup$ – user58715 Jul 7 '19 at 16:57
  • 1
    $\begingroup$ How about increasing the Distance? $\endgroup$ – metaphor_set Jul 7 '19 at 19:15
  • $\begingroup$ I'm selecting first the hight poly mesh. No reason for freestyle box, today I became crazy and I started to try random options (not a good way to do thing), now I deselected it. I tried to follow a tutorial in cycles but when I press bake blender crash. I played with all the possible parameters but nothing change. $\endgroup$ – Mauro Conte Jul 7 '19 at 21:00
1
$\begingroup$
  1. in 3D View: you may have made a mistake in the scale, always keep in mind to apply scale CTRL + A select SCALE and ROTATION
  2. play a little configuring the maximum distance and the minimum distance, until you get an optimal result or that you like
  3. in edit mode, remember to apply the normal orientation of the faces towards the exterior, to check this you can turn on the normal indicator in mesh display , select all and press CTRL + N
  4. with respect to the Subdivision surface modifier, you can also play with the levels to see a result that you like, my example is done with this configuration

Blender Tutorial : Part 17 - Normal Mapping (Blender) example One Example Two your settings adjust face normals Subdivision surface modifier your subsurf settings

$\endgroup$
6
  • $\begingroup$ yes you have completely reason I made some mistakes in 3d. Now I applied scale and rotation and I can see in the menu that the two object have the same scale and rotation. In edit mode I applied to both meshes in edit mode normal orientations and if I select to show face normals I can see light blue lines coming out. But when I try the final step nothing change. I really played with the parameters distance and offset. $\endgroup$ – Mauro Conte Jul 7 '19 at 20:44
  • $\begingroup$ in any case really thank you for the answer, at least i learned something $\endgroup$ – Mauro Conte Jul 7 '19 at 20:50
  • $\begingroup$ it's strange, maybe this is a blender file, because it works on all the attempts I had in other blends, can you upload your blend, to be able to check where the error is? Upload Blender StacK Exchange $\endgroup$ – user58715 Jul 7 '19 at 22:50
  • $\begingroup$ i add a video tutorial, my answer is very good, pleas vote up or accept the answer $\endgroup$ – user58715 Jul 7 '19 at 23:07
  • $\begingroup$ @Muro Conte you have an error in the UV MAP, it is not necessary to have the HiPoly Object UV map, but the LowPoly object must have a map of normal because it is where the information will be deposited, at least that's the way I learned what is done and it has always worked well for me $\endgroup$ – user58715 Jul 8 '19 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.