1
$\begingroup$

I am attempting to build a light beam and so far it works as long as there is no objects behind. Once it steps over an object that is behind, the intensity seems to diminish its power depending on the qualities of the material behind.

I would like this not to happen, as I need a homogeneous streak. How could elements be influencing this scene and how could I change it?

Blender file: http://we.tl/H7hwWtIqLL

A visual example:

Particles affected by an object behind

$\endgroup$
2
  • $\begingroup$ Please upload a blend file so people can look at your setup. $\endgroup$ Jul 28 '14 at 12:14
  • $\begingroup$ I have just uploaded it :) $\endgroup$
    – Guillem
    Jul 28 '14 at 12:44
1
$\begingroup$

The problem is caused by the transparent material of the blue 'Cylinder'. You can fix this by going to its material and then under the Transparency tab and setting your transparency method from 'Z Transparency' to 'Raytrace'. This should fix your problem!

$\endgroup$
2
  • 1
    $\begingroup$ That fixed the problem, thank you very much! $\endgroup$
    – Guillem
    Jul 28 '14 at 14:21
  • 1
    $\begingroup$ Would you like to asign my answer as usefull please so other people know the solution has been found... $\endgroup$
    – Bert VdB
    Jul 28 '14 at 14:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.