0
$\begingroup$

Why am I getting this banding artifact and not getting translucency (e.g through the ear)? In the various online demonstrations of EEVEE's SSS I've looked at, there's not banding and translucency works. Is there some setting I'm missing?

My setup is one lamp that's behind Sussanne, and Sussanne's material is Principled BSDF with SSS=1 and transmission=0. It's Blender 2.8 for Mac OS.

The two images below show the banding effect.

  • In render settings, the SSS samples count changes but doesn't remove the banding.
  • In render settings, the jitter amount has no effect.
  • In render settings, "screen space refraction" on/off has no effect.
  • In material settings, "subsurface translucency" on/off has no effect.

enter image description here enter image description here

$\endgroup$
3
$\begingroup$

I discovered through more experimentation that subsurface value set to 1.0 is extremely high. Values below 0.3 don't exhibit these artifacts. Also:

  • moving the light further away from the object reduces artifacts even at sss=1
  • it's not necessary to turn on screen space reflection/refraction
  • SSS translucency does work. I don't know why it wasn't working when I created those screenshots. Maybe I just needed to reboot, or maybe I had some weird settings.
$\endgroup$
3
$\begingroup$

Under Render Settings look for Subsurface Scattering and crank up the Samples. I set it to 32 and got rid of that banding effect.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.