0
$\begingroup$

I've been having trouble getting the texture painting to work right.

My problem is when I paint directly on my model in the 3D view the paint stroke goes to the back of where I painted, like if I paint of his chest it shows up on his back, if I paint on his face it shows up on the back of his head.

All my painting down within the UV window shows up in the correct places, though.

I haven't been able to figure out what is causing this problem. I'm wondering if I have a setting that is off that I don't know about or if something is off with my model. I've tried exporting my model and making new scenes with the export and each one has had a problem with painting.

$\endgroup$
  • 1
    $\begingroup$ Try to recalculate the normals $\endgroup$ – moonboots Jul 3 at 20:11
  • $\begingroup$ How do I ensure the normals are facing the correct way? $\endgroup$ – Hanna Pepper Jul 3 at 20:18
  • $\begingroup$ Okay so, It was indeed a normal problem. My normals work backwards. $\endgroup$ – Hanna Pepper Jul 3 at 21:01
  • $\begingroup$ I have to say, it was obvious in 2.7, in 2.8 it's not but I must be missing something, anyway in Edit mode you can activate a Face Orientation option in the Display Overlays options, and you can see that the mesh is completely red, so it's indeed the normals that you need to flip with a select all and shift N $\endgroup$ – moonboots Jul 3 at 21:02
  • $\begingroup$ Hey, thank you so much. I had no idea how to even check what my normals looked like. $\endgroup$ – Hanna Pepper Jul 3 at 21:06
1
$\begingroup$

It's a Normals issue, in 2.8, in Edit mode, select all and shiftN to recalculate the normals

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.