0
$\begingroup$

I am creating an animation that shows the assembly of a Meccano toy (erector set).

I am not concerned with showing any shadows or reflections, I just want my objects to be simple colors.

How should I approach lighting and material settings to get the fastest render times?

$\endgroup$
4
  • $\begingroup$ I don't know if this has been suggested, but turning down sampling could help. $\endgroup$ – user2442110 Jul 28 '14 at 5:17
  • $\begingroup$ In future, please be a little more specific in your questions so that we know exactly what you're looking for and how to answer. $\endgroup$ – Greg Zaal Jul 28 '14 at 8:24
  • 1
    $\begingroup$ If all you want are flat colors, you might try using the OpenGL render. $\endgroup$ – gandalf3 Jul 28 '14 at 22:44
  • $\begingroup$ OpenGL render is also an excellent suggestion. Never knew about that option. $\endgroup$ – Tom Berghuis Jul 29 '14 at 3:20
3
$\begingroup$

The fastest flat-colour renders usually come from using Blender Render, although it's also possible in Cycles which may be quicker if you have a lot of geometry.


Blender Render:

All you need to do is enable Shadeless on all your materials, and then the diffuse colour will be what controls the colour of that object.

BI shadeless

To be doubly sure you're not calculating anything unnecessary, delete any lights in the scene and disable all the Shading options in the render settings (except for Textures if you have any textures applied)

BI Render settings


Cycles:

Use an Emission Shader - this will indeed emit light (onto any other kind of shaders), but it won't have any shading on it and renders quickly.

Cycles Emission

If you do that for all your materials, then there won't be any other surfaces to emit light on to. However, if you do have a few diffuse surfaces and want to prevent the objects from emitting light, just disable all but the Camera rays for that object:

Cycles Camera rays

Finally, just to make sure it's as fast as possible, set the render Samples to something reasonable like 32 or 64 (or even lower if you're not too fussed about crisp edges), disable Shadows and set the Max and Min bounces to 0:

Cycles Render settings


If CPU is not being used fully:

Finally, while it's rendering take a look at your CPU usage in your OS's task manager. If it's not using 100% of the CPU, it can help to render with more than one Blender at a time:

Placeholders

If you disable Overwrite and enable Placeholders, Blender will create a small place-holder image as it starts rendering and won't rerender any frames where the image already exists. This way, if you open another Blender and render the exact same thing at the same time, they won't overlap and will be able to render at double the speed (unless of course your CPU usage was above 50%).

You might still never get to 100% CPU usage if you're limited by your hard-drive/network speed or the amount of RAM available.

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.