0
$\begingroup$

I have some issues in my model:

Shade smooth1

Shade smooth12

I was asking about this issue on other forums, but no one helped me.

One person said that I have to learn what is topology first, before starting modeling. I did that, but I didn't find any new information. I have topology without N-gons and even with quads only:

Topology1

Topology2

Another person said: "Learn how to work with this instrument". But I didn't find any options in "Shade smooth" option. I only found how to make no smoothing on edges that we need.

Another person said: "Add subdivision Surface". But it will add some extra vertices that don't need for geometry shapes. They will just overload my model. I can use bevels instead if I need some smooth shapes on edges. Am I right?

Someone said that my vertices are too over stretched in this place. But I have the grip and the rear part of my gun and other parts that have stretching too, but there aren't any artefacts:

Over stretching

I was trying Shift+N, but nope. So I enabled the 'auto smooth' option with values under 50 degrees (because over this value there are some artefacts appearing again):

Auto smooth1

Auto smooth2

Is this the right way to solve this problem? Or where is my mistake? What did I do wrong?

$\endgroup$
0
$\begingroup$

Adding an edge split modifier might help. Set the split angle roundabout 15° or a similar value... This modifier splits all edges, which form a sharp boundary (which shouldn't look smooth). Often this also solves some surrounding smooth errors which are caused by smoothed edges which are quite sharp.

$\endgroup$
  • $\begingroup$ Yeah, but it adds some additional vertices (in my case in 2 times more vertices), and when i push "Merge by distance" with value 0.0001m all are going to the same issues. Is this okii? $\endgroup$ – Hyp_Hyp Jul 1 at 13:42
  • $\begingroup$ You do not need to apply the edge split modifier. Just put it at the end of the modifier stack. Moreover only the sharp edges (set by the angle in the modifier properties) will be split, so there shouldn't be 2 times as much vertices $\endgroup$ – Robert Roth Jul 1 at 13:46
  • $\begingroup$ Maybe i will want add some additional details on my models. So i had to add some new meshes and then connect one to this mesh. Or there are some trouble appears, because i forgot to denied "extrude" option so there are the same vertices in the same place. And when there is a lot of vertices i can't remember or find where my mistake is, so it is easy just press A and "Merge by distance" button. $\endgroup$ – Hyp_Hyp Jul 1 at 13:50
  • $\begingroup$ Oh, allright! Thanks for the answer! :D But can't i use just "Auto smooth" then? Because it doesn't add any extra vertices, but makes the same results. $\endgroup$ – Hyp_Hyp Jul 1 at 13:52
  • $\begingroup$ Yes, it seems that the Autosmooth function is a nice alternative to edge split! $\endgroup$ – Robert Roth Jul 1 at 16:30
0
$\begingroup$

I found a good solution! Mark sharp edges you need and then press Auto smooth and choose 180 grad. value.

Why can't we just put auto smooth? I don't know, but the person, who gave me this advice, is working in gamedev industry and he was reading about that in documentations.

So if you don't wanna export your models in another game engines, you can just put autosmooth with any acceptable values.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.