0
$\begingroup$

I am working on my second project with Blender and I have a very weird bug.

I import Alembic files created with Quill and I time correct it with expressions to reproduce the stopmotion look (6fps or 12fps, converted to 25 fps).

It works well in the viewport and I already rendered my previous project with success in Cycles. Unfortunately, when I try to render my full scene with Eevee, my loops seems broken, and the animation becomes weirdly jerky and random.

On this short gif, you can see that the character animation is not smooth (sorry for the bad quality of the gif, it is limited by this website) :

enter image description here

When I try to unactiv some objects from rendering, it can randomly works again, but there isn't a specific object responsible of the bug.

It looks like that Eevee is randomly bugging with Expressions (or Alembic) when I have too many layers. I tried with differents Blender releases, it is still the same.

Is it a known problem ? Do you have suggestions to bypass this problem and finish rendering?

Thanks !

$\endgroup$
  • 2
    $\begingroup$ Welcome to the site! Firstly, please ask only one question per question. If you have multiple questions, ask multiple questions. Otherwise people might know an answer to your first but not to your second question and thus won't write an answer. Secondly, what do you mean when you say you try to "unactiv" layers and the animation looks "jerky and random"? Could you maybe even provide images, gifs or the .blend file (upload it to blend-exchange.giantcowfilms.com)? $\endgroup$ – palkonimo Jul 1 at 15:46
  • $\begingroup$ Thank you for your comment. I edited my post, I hope it will be more clear. $\endgroup$ – Stef Jul 2 at 15:11
0
$\begingroup$

Here is the expression I use to loop and keep the stop motion effect :

(round(25*round(frame*wantedfps/globalframerate)/wantedfps) - 1) % animationlenght+ 1

It works in the viewport, or with Cycles and lightweight scenes in Eevee. But it doesn't work with my scene with Eevee until I unactiv some objects.

$\endgroup$
0
$\begingroup$

I think there is a synchronisation bug with the drivers in Blender 2.8, but I can't isolate it. So, I used the fcurves in the graph editor to do the same thing.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.