I'm learning displacement node setups and I can't seem to get it to work properly. The height map seems not to be in sync with the rest of the maps, although I've checked with node wrangler that all maps are in the right place and overlaying without shifting.

I've plugged the Height map into a displacement node with the color output in the displacement height input.

The material settings are set to displace only. All maps are connected to a mapping node and have the same coordinates. The model is UV unwrapped properly. The edges of the model are mean creased to full 1.0. I'm using cycles with GPU compute.

Q: Anyone know where this shift in displacement comes from?

Q: And as a bonus, how to make the displacement look better? I've subdivided the plane 30*30 and added a Subsurf modifier in setting 4 and it still looks jagged.

Node Setup

Node setup


Viewport render

Texture settings:

Texture settings

  • 1
    $\begingroup$ In order to get displacement working, your model needs to have much, much more subdivisions. $\endgroup$ Jul 1, 2019 at 0:26
  • $\begingroup$ subsurf modifier too might help $\endgroup$
    – Corbomite
    Jul 31, 2019 at 18:28

1 Answer 1


On the Height Node: - Change the space color on the height map from sRGB to non-color


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .