When a transparent material hits a surface with ss enabled, the edges appear blueish. The only way I could fix it is by enabling Screen Space Refractions on the hair, but that disables all the shadows it casts on the skin. Any known fix?

enter image description here


Eevee treats transparent objects differently than Cycles. They are sorted from front-to-back per object and do not receive any screen space effects.

This is fast and works fine for many cases, but it is only approximate and gives incorrect results for some object shapes. For more accurate results, enable Alpha Hashed transparency in the material. With a sufficient number of samples to resolve the noise, this gives accurate transparency.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.