1
$\begingroup$

Working in 2.79, I'm attempting to work on a grassy field, may extend to a larger background piece later, but currently I hit a wall in production. After many troubles texturing my particle system, I gave everything a material and rendered, but no matter what I do, my plane doesn't render, just the particles.

I've even attempted duplicating the plane and removing the particle system from the duplicate to just have it sitting beneath it, but that doesn't work.

I've changed materials to one I know isn't transparent, so it isn't a problem with the material, and I can't, for the life of me, find anything in object, material, or render options that can fix it.

Edit: I started with a simple plane and subdivided, fractal'd, etc. to get the shape I wanted. I went through making four different sets of grass clumps for my particle system and set it to pick randomly from that set, and gave it a cloud texture for good dispersal of the particles.

My settings, limited to relevance, are attached in images, if all works correctly...

Here, my settings.

Despite this, below is an attached image depicting what I get in render. Notice my brown material for the plane doesn't show up. I made the background transparent in order to make it clear that my plane just... isn't there.

No plane

$\endgroup$
  • $\begingroup$ Please use the edit link at the bottom of your question (i.stack.imgur.com/lXFuK.png) and add more information on how you set up your project and the particles. Add images that might help us understand your scene and settings. See How to upload an image to a post? $\endgroup$ – cegaton Jun 27 at 15:41
  • $\begingroup$ Editted, hopefully this is more clear now. $\endgroup$ – David Jun 27 at 16:43
  • $\begingroup$ Welp... I feel dumb. I just found that my Shadow Catcher option was on, and that was what caused it. $\endgroup$ – David Jun 27 at 17:09
  • 1
    $\begingroup$ @DuarteFarrajotaRamos that was the answer indeed, why turn it into a comment? $\endgroup$ – cegaton Jun 27 at 17:36
  • $\begingroup$ Well it felt unsubstantial and read more like a comment than a full answer, but I can reinstate. It also has a downvote so it might need some love $\endgroup$ – Duarte Farrajota Ramos Jun 27 at 18:38
2
$\begingroup$

I just found that it was not related to particles but a completely different setting. The Shadow Catcher option that was turned on on the plane, and that was what caused it.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.