1
$\begingroup$

Thank you for taking the time to look into this. I am having a couple of issues exporting for use inside of Unreal Engine 4. The problem the engine is giving me is that 87% of my UVs are overlapping. This causes the lighting to look extremely off and casting shadows in strange place, such as on a roof shingle's face in sunlight.

So far to fix this problem, I have applied all modifiers, selected all objects, and then SMART UV unwrapping all objects together to create a single UV. This still results in an error. I then decided to join objects before doing so, nothing so far. After that, I went row by row and boolean modified the roof shingles together. This also doesn't help. Next, the island margins for the UVs were increased to an absurdly large amount just to see if it fixed anything. The UVs overlapping drastically decreased to 5.7% but the problem persisted. I have also attempted to repack the islands multiple times, also trying cube and cylinder methods. This is the image of the UV mapping (Warning it looks monstrous):

uv mapping

The extreme amount of mapping is due to the repetition of rooftop shingles which each have their own mapping. I do not know how to fix this either. The problem I am prioritizing right now is the overlapping UVs. A closer look at the UV will also reveal this:

enter image description here

I would think it is safe to assume that the small white triangles are showing the overlapping UV areas. Knowing this, I am still not sure what to do to fix it. Thank you for you time ' >'

EDIT: I should add that deleting the roof shingles entirely fixes the problem. It seems that the roof shingles is the root cause.

$\endgroup$
  • $\begingroup$ Check that you have no overlapping /double faces on your model. Fiddling with the margin setting in the smart project operator may also help reveal some details. $\endgroup$ – Sazerac Jun 27 at 3:35
  • $\begingroup$ Also check for n-gons, since they can unwrap in weird ways sometimes. $\endgroup$ – Sazerac Jun 27 at 3:36
  • $\begingroup$ Hi Sazerac, I looked back at the roof shingle to check for n-gons and doubles. I deleted faces and such and couldn't find any doubles, and there seem to be no ngons to me. However, I decided to try and mark a seam to see if that would help, and indeed i am no longer getting errors for overlapping UVs (checking on two rows only). $\endgroup$ – Torhara Jun 27 at 3:59
  • $\begingroup$ Thats weird. If you can figure out a good explanation, write up an answer. $\endgroup$ – Sazerac Jun 27 at 4:05
  • $\begingroup$ Yep, thanks so much for the response though. I guess Blender was having troubles without any seams marked? Here is the shingle by itself in case you wanted to see it: imgur.com/a/fIBQLNi ... I can kind of see how it might have messed up with that face going in maybe.. Marking the seam on the shingle and redoing a UV Smart Projection fixes my issue. $\endgroup$ – Torhara Jun 27 at 4:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.